locked
"No Audio Device" when connected to server via the console or remote desktop RRS feed

  • السؤال

  • Hi

    I have all my music files stored on my WHS. I have a number of media players around the place accessing the files via the Jamcast UPNP music server installed on the WHS (which I felt had some advantages over Windows Media Connect).

    Sometimes I also want to be able to broadcast the same stream to all the players. Jamcast has a "virtual soundcard" which broadcasts whatever is playing on the server's local audio device. If I log into the server itself, I can start a track or playlist in Media Player, and Jamcast picks it up and sends it out as planned. However if I log on to the server from one of the clients (which is preferable) using the Windows Home Server console, or Remote Desktop, trying to play any sound generates a C00D11BA error and the following message:

    "Windows Media Player cannot play the file because there is a problem with your sound device. There might not be a sound device installed on your computer, it might be in use by another program, or it might not be functioning properly."

    The "Sounds and Audio Devices" applet in Control Panel bears this out. At the server itself the Sound Recording and Sound Playback devices are set to the Realtek HD Device. Via remote desktop, the Sound Playback device is Microsoft RDP Audio Driver (with no other option available) and the Sound Recording device is blank, with no options at all.

    Summary:

    How can I access the server's audio devices from within a Remote Desktop/WHS Console session?

    TIA for any help

    Vaughan 
    20/ربيع الثاني/1431 11:08 ص

الإجابات

  • I don't have any servers with sound cards, so I'm not able to say for sure what might be going on. But try mstsc -v:servername -console and -admin instead. I can think of some other possibilities, but there are security issues...
    I'm not on the WHS team, I just post a lot. :)
    • تم وضع علامة كإجابة بواسطة Vaughan_D 21/ربيع الثاني/1431 08:37 م
    20/ربيع الثاني/1431 09:58 م
    المشرف

جميع الردود

  • What you're seeing is by design. Normal Remote Desktop connections don't support playing media local to the server, only sending the audio stream to the remote computer for play there.

    It should be possible to get the audio to play local to the server, however. You will need to establish a connection to the console session on your server, by running the Remote Desktop client using the /console parameter.

    You should keep in mind that remote desktop connections to your server are not supported by Microsoft, so there are tools available that can cause serious problems with your server. Also, using your server in this way is a violation of the EULA, which prohibits using Remote Desktop for other than basic administrative functions. (Not that I think Microsoft is likely to hunt you down for it...)


    I'm not on the WHS team, I just post a lot. :)
    • تم الاقتراح كإجابة بواسطة Ken WarrenModerator 20/ربيع الثاني/1431 02:11 م
    20/ربيع الثاني/1431 02:11 م
    المشرف
  • Thanks for your response, Ken.

     

    I tried opening a command window and running:

    mstsc /v:servername /console

    ... but that just opened another session. So I tried:  

    mstsc /v:servername /admin

    ... That did seem to connect to the console session, but without any audio devices as I described in my original post. Is that to be expected? Have I used the wrong syntax somewhere?

    Thanks again

    Vaughan

    20/ربيع الثاني/1431 06:18 م
  • I don't have any servers with sound cards, so I'm not able to say for sure what might be going on. But try mstsc -v:servername -console and -admin instead. I can think of some other possibilities, but there are security issues...
    I'm not on the WHS team, I just post a lot. :)
    • تم وضع علامة كإجابة بواسطة Vaughan_D 21/ربيع الثاني/1431 08:37 م
    20/ربيع الثاني/1431 09:58 م
    المشرف
  • Many thanks for your help Ken. This is what worked in the end:

    mstsc -v:servername -admin

    PLUS setting remote sound to "Leave at remote computer", which seemed to be the key.

    Thanks again

    Vaughan

     

    21/ربيع الثاني/1431 08:40 م
  • The answers below didn't work for me.

    In my case, my machine was part of corporate network, and had a group policy preventing Audio being enable when logging in remotely.

    The solution is:

    1. Open command prompt (cmd.exe) as administrator.
    2. Type "gpedit" (without the quotes) and press Enter.
    3. Go to Computer Configuration --> Administrative Templates --> Windows Components --> Remote Desktop Services --> Remote Desktop Session Host --> Device and Resource Redirection.
    4. Double click on "Allow audio and video playback redirection".
    5. Select "Enabled", type "Yes" (without the quotes) in the Comment text box.
    6. Click "Next Setting".
    7. Make sure it's "Allow audio recording redirection" and do the same.
    8. Click OK.
    9. Log off (not only your remote desktop session, but your current actual session) and log on again, making sure "Bring audio to this computer" is select in your remote desktop options (as described in the this thread).

    Guyguy

    • تم الاقتراح كإجابة بواسطة Frankothemountain 10/جمادى الثانية/1439 03:15 م
    24/جمادى الأولى/1433 09:32 م
  • hi ,  

    i'm trying to do the exact same thing in my WHS 2011 becaus i want to play music from itunes to the local soundcard that works with USB.

    it works when i login with a monitor attached , but the moment i try with rdp i there are "no audio playback devices" , i tryed the -admin thing and also group policy settings ... nothing seems to work.

    this really bugs me , do you have a sollution ?

    friendly regards.

    04/صفر/1434 04:32 م
  • RDP to server

    Start-Control Panel-Administrative Tools-Remote Desktop Services-Remote Desktop Session Host Configuration

    RDP-tcp- right click properties

    Client Settings uncheck audio and video play back

    Discoonnect

    RDP to server click audio option-Check Remote Audio

    Ensure RDC is configured also RDC - Show options - Local Resources Settings - Play on this computer

    11/صفر/1434 12:39 ص
  • Excellent, thank you.
    10/جمادى الثانية/1439 03:15 م