none
@SYS372 RRS feed

  • Spørgsmål

  • Hej - håber at der en der kan hjælpe mig:

    Vi har 3 PC'er der kører C5, men 2 af dem kan ikke starte C5 rigtigt op. Alle menuer og tekstboxe skrives der @SYS72443 eller @SYS372, i stedet for den rigtige tekst.

    De 2 PC'er der har problemer har en lidt anden Windows version, en den der virker.

    Microsoft Dynamics C5 Version 4.4.1.371
    Win 32 native
    Domain login
    Afvikles fra server/Domain Controller

    Windows version der virker:

    Version 1903
    18362.778

    Windows version der ikke virker:

    Version 1909
    18363.836


    19. maj 2020 12:11

Alle besvarelser

  • Hej Henrik

    Jeg har ikke arbejdet med C5 i næsten 2½ år, men lad mig prøve alligevel.

    Det du ser (@SYSxxxxx) er såkaldte labels.

    Det er C5s måde at implementere brugergrænseflade på flere sprog på. Alle tekster er internt lagret som @SYSxxxxx-koder, og den "label" kan så slås op i en sprogfil, så man på dansk ser det tilsvarende danske tekst, på engelsk den tilsvarende engelske tekst osv.

    Mit bedste gæt på årsagen til det du ser er derfor at de 2 PCere mangler eller ikke kan åbne disse sprogfiler.

    De filer du specifikt "mangler" hedder c5sysald.<sprog - fx uk eller dk>, samt tilhørende c5sysald.<sprog> og c5sysali.<sprog>. Så vidt jeg husker er c5sysald.* blot en tekstfil du kan åbne i windows notepad (men lad være med at gemme dem igen), så det oplagte er lige at lokalisere filerne på alle 3 PCere og checke at du kan åbne dem i notepad. Kan du det og ligner det hinanden kan alle 3 PCere i hvert fald læse filerne (kan de ikke, er der nok nogle rettigheder eller lign. der driller på serveren).

    Sekundært har C5 en fil kaldet C5.INI, hvor der kan defineres hvilke sti'er der skal søges efter filer. Det er også en tekstfil, så du kan med fordel checke om det der står i den giver mening.

    Endelig kan noget så simpel som opstartskataloget på det ikon du bruger til at starte C5 med påvirke det her. Så kontroller egenskaberne for genvejene på alle 3 PCere og check at de står til at starte på samme katalog.

    Håber det hjælper dig videre.

    PS: er du interesseret kan du læse lidt omkring de forskellige C5-filer i et gammlet blogindlæg jeg har lavet. Det finder du her: https://scblog.lynge.org/?p=326

    MVH

    Gert Lynge


    MVH gl@simteq.com Se også: http://scblog.lynge.org/


    19. maj 2020 17:27
  • Hej Gert 
    Mange tak for dit svar.

    Jeg kan åbne C5.INI - som ser sådan her ud:
    ; Comments Here
    [C5DbSettings]
    -d.\;Country\dk;
    -wc:\c5tmp
    ;-usupervisor

    Jeg kan også åbne c5sysald filer, som har de tekststrenge der henvises til

    Her til morgen fejlede også den 3. maskine, der har en anden Windows version.

    Til gengæld kunne jeg kopiere hele C5 ud fra netværksdrevet på serveren, og lægge det på C drevet, herefter virker C5 fint.

    Jeg kan desuden starte det direkte fra serveren uden problemer, så det må jo betyde at problemet ligger i at afvikle C5 over netværket?

    Serverens E drev er mappet som et K drev på klient maskinerne, og og alt køres herfra.
    Det er en Windows 2012 server- Version 6.2 Build 9100)

    har i nogen bud her?
    20. maj 2020 06:56