Unable to load dll HRESULT: 0x8007007E RRS feed

  • Question

  • I have moved a C# project from Visual Studio 2003 to Visual Studio 2005 Express.

    I get the "unable to load dll HRESULT 0x8007007E" error when making a call to an unmanaged dll. This previously worked OK before.

    I have tried putting the dll into the bin\debug directory, the windows and system32 directories with no success.

    I have also added the debug directory to the environment path variable but still no success.

    I have investigated trying to put a dependancy in the project on the dll but can't find a method of achieving this.

    I have also tried running the application and the dll outside of the IDE in the same directory and it still can't find the dll.

    Is there a difference in the way Framework 2.0 loads unmanged dlls compared to 1.1?

    Additional information. I have both 1.1 and 2.0 Frameworks installed. The project still works in Visual Studio 2003.

    Any help would be appreciated.



    Saturday, July 8, 2006 8:20 AM


  • The DLL might itself require some other DLL.  In case of doubt, use Dependency Walker...

    Saturday, July 8, 2006 9:57 AM

All replies

  • The DLL might itself require some other DLL.  In case of doubt, use Dependency Walker...

    Saturday, July 8, 2006 9:57 AM

  • Thanks,

    Its not until somebody says something blindingly obvious that a light bulb switches on.


    Saturday, July 8, 2006 12:16 PM
  • I had the same issue before. You have to check two choices...

    1- You location isn't correct
    2 - You have dependencies. Maybe in your Visual Studio 2003 you had another path within your project path. Check them to see what it is. Some folder is included you need to find which.

    Take a look at http://www.dependencywalker.com/ and you can see if your dll requires another dll.
    Saturday, July 8, 2006 1:17 PM
  • Hi,


    I'm looking for a solution for a same kind of problem.

    I have a visual studio 2005 vb-service which make use of multiple dlls.

    These dlls exist in two versions: say unicode and not unicode.

    The difference in a pair of dlls is made by build configurations in visual studio 6.

    Some of this dlls have dependencies on other ones.

    However, my unicode dll still has dependencies with some non-unicode ones where it depends on.

    And this generates an error in my service ( Unable to load dll ... )

    I have checked all the settings in my project and even make some changes in the dsp-file but still it gives the same error.


    Can someone give my an advice that brings me closer to a breakthrough?

    Thanks in advance.


    Thursday, February 28, 2008 4:29 PM
  • I'm problem with my WINDOWS XP PROFESSIONAL SP2- in OPEN the Windows, see a message:

    your SQLServer Installation is either corrupt or has been tampered with (Unable to Load SQLBOOT.DLL)  HRESULT 0x8007007e please uninstall then re-run setup to correct this problem.






    Wednesday, April 16, 2008 1:09 AM
  • Hi All,

    Could you Please confirm ---You have the SQL server in it but it is faling to start the SQL serverand Logging the error Unable to Load SQLBOOT.DLL


    Try to copy the SQLBOOT.DLL from your SQL serverInstallation kit and Paste to the

    following location "C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\Binn     "


    Seems the SQLBOOT.DLL is missed or corrupted do the aboce steps as I mentioned and try to start it.


    Thanks and Regards,


    Monday, October 18, 2010 4:09 PM
  • Yah, the dependency walker doesn't work well if you have a missing dll. This is a common problem for those upgrading a 32 bit web application to IIS running on a 64 bit Windows OS.

    If you're running a web application on a 64 bit machine, you need to download the following dll file and stick it into your C:\Windows\SysWOW64\ folder.  Microsoft forgot to ship this file with Windows 7 and Windows Server 2008.


    File size:
    340 KB (348,160 bytes)

    Wednesday, February 16, 2011 3:54 PM
  • hey, I have a similar problem, except mine is from a C# program trying to call a managed c++ dll, which is a wrapper for an unmanaged c++ dll.  When I call a function that declares a variable of a class in the dll wrapper i get the error.  Am i supposed to run the dependency walker on the C# exe file?  What should I be looking for in the dependency walker output to diagnose the problem?




    Wednesday, July 6, 2011 6:58 PM
  • never mind, I figured it out.  i was missing a dll in the folder
    • Proposed as answer by _413X_ Wednesday, July 6, 2011 7:39 PM
    Wednesday, July 6, 2011 7:39 PM
  • For me this was de solution, thank you very much
    Friday, January 18, 2019 12:13 AM