locked
How to disable autoconfiguration IPv4 ? RRS feed

  • Pytanie

  • Ethernet adapter Local AreaConnection 2:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Intel(R) PRO/1000 MT Network Connection #
    2
       Physical Address. . . . . . . . . : 00-50-56-B3-22-34
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv4 Address. . . . . . . . . . . : 82.179.190.12(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.128
       Default Gateway . . . . . . . . . :
       DNS Servers . . . . . . . . . . . : 127.0.0.1
       Primary WINS Server . . . . . . . : 127.0.0.1
       NetBIOS over Tcpip. . . . . . . . : Enabled

    ---------

     

     

    The problem is that my static IP is constantly replacing with "autoconfiguration". Ipconfig output says "Autoconfiguration Enabled . . . . : Yes"

     

    Question: How do I disable, turn off the "Autoconfiguration" ?

    ps. IP address is statically configured.

    wtorek, 23 listopada 2010 12:56

Odpowiedzi

  • Hello,

    the Autoconfiguration belongs to APIPA which is only used if a DHCP server is not available(if enabled) or NO fixed ip address is configured, which you did.

    So what problem do you have if it is enabled? Anyway, check this option:

    This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly.

    Disable APIPA on All but One Network Adapter

    1. Use Registry Editor to create the following registry key, where <var>adapter name</var> is the name of the Dynamic Host Configuration Protocol (DHCP) configured adapter where you want to disable APIPA:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\ Services\Tcpip\Parameters\Interfaces\<var>adapter name</var>
    2. Add the following value to this key:
      Value name: IPAutoconfigurationEnabled
      Value type: REG_DWORD
      Value in hexadecimal: 0 (A value of 0 disables APIPA support on this adapter)
      NOTE: If the IPAutoconfigurationEnabled entry is not present, a default value of 1 is assumed, which indicates that APIPA is enabled.
    3. After you make this change, restart your computer.

    Best regards Meinolf Weber Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.
    wtorek, 23 listopada 2010 13:07

Wszystkie odpowiedzi

  • Hello,

    the Autoconfiguration belongs to APIPA which is only used if a DHCP server is not available(if enabled) or NO fixed ip address is configured, which you did.

    So what problem do you have if it is enabled? Anyway, check this option:

    This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly.

    Disable APIPA on All but One Network Adapter

    1. Use Registry Editor to create the following registry key, where <var>adapter name</var> is the name of the Dynamic Host Configuration Protocol (DHCP) configured adapter where you want to disable APIPA:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\ Services\Tcpip\Parameters\Interfaces\<var>adapter name</var>
    2. Add the following value to this key:
      Value name: IPAutoconfigurationEnabled
      Value type: REG_DWORD
      Value in hexadecimal: 0 (A value of 0 disables APIPA support on this adapter)
      NOTE: If the IPAutoconfigurationEnabled entry is not present, a default value of 1 is assumed, which indicates that APIPA is enabled.
    3. After you make this change, restart your computer.

    Best regards Meinolf Weber Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.
    wtorek, 23 listopada 2010 13:07
  •  
     Connection-specific DNS Suffix  . :
     Description . . . . . . . . . . . : Intel(R) PRO/1000 MT Net

     Physical Address. . . . . . . . . : 00-50-56-B3-01-C1
     DHCP Enabled. . . . . . . . . . . : No
     Autoconfiguration Enabled . . . . : Yes
     IPv4 Address. . . . . . . . . . . : 10.10.0.2(Preferred)
     Subnet Mask . . . . . . . . . . . : 255.255.0.0
     Default Gateway . . . . . . . . . :
     DNS Servers . . . . . . . . . . . : 127.0.0.1
     NetBIOS over Tcpip. . . . . . . . : Enabled

    After i've done this,  should i get   Autoconfiguration Enabled . . . . : Yes  ?


    wtorek, 23 listopada 2010 14:27
  • Hello,

    How to know my adapter name??

    ty

    wtorek, 14 sierpnia 2012 06:42
  • In case someone else runs across this...the problem might not be that Autoconfiguration is enabled, but that the assigned IP address is in use.  I had the same issue & tried the registry key, but still couldn't ping my gateway - but sure enough checked in DNS & the IP assigned by VMM was in use and was being actively used.  Found an old IP that was free, set that as the server's IP address and the server's working just fine now.

    • Zaproponowany jako odpowiedź przez R Oliver wtorek, 14 maja 2013 12:08
    poniedziałek, 22 kwietnia 2013 17:35
  • i try these steps but still not working on my server 2008 r2 still its shows Autoconfiguration Enabled . . . . : Yes

    please help me


    paul

    • Zaproponowany jako odpowiedź przez paul0003 wtorek, 9 lipca 2013 05:56
    • Cofnięcie jako propozycji odpowiedzi przez paul0003 wtorek, 9 lipca 2013 05:56
    wtorek, 9 lipca 2013 05:54
  • Hi Steve Thanks... your Solution resolved my issue !!
    czwartek, 21 sierpnia 2014 03:44
  • Paul, you could check if there is a second IP somewhere in old defunct NICs...do ipconfig /all ..and check if your prefered ip is marked as duplicate...then you go for steve advise..above..thanks..
    czwartek, 21 sierpnia 2014 03:46
  • I have the same problem, and I hope I haven't totally trashed my registry since no install sector was on this machine when I bought it. Nothing works, my lan insists on deleting or replacing my specified ip I am paying the provider company for.. and nothing has any beneficial effect whatsoever. I cannot get online (where MS keeps telling me to go for help and support) unless I go get another computer that DOES function as advertised.

    We seem to have the same problem, all the solutions are big on 'do this and that', and very light on 1)how to find this and that, 2) how to identify this and that, and 3) how to DO this and that.  I mean if this is help - it must be from helpful experts who expect everyone else to be experts as well, in which case they are unnecessary.

    I guess what I am saying is thanks for nothing...

    sobota, 7 listopada 2015 19:44
  • adapter name? seriously, the make, the model or the name its mother gave it? a binary name assigned by the computer? I have tried to find and use them all, to no avail... even tot he point of actually trying 'adapter name' as a name... no joy. my specified ip is wiped or replaced every time.
    sobota, 7 listopada 2015 19:46
  • I have no autoselect ip - specified ip, and it is continually deleted or replaced... all above remedies do not work. windows seven ultimate (pain in the .......)
    sobota, 7 listopada 2015 19:48
  • To fix it, enter this from Command Prompt:

    C:\Users\Administrator> netsh interface ipv4 show inter      


    result as:

    Idx Met MTU State Name
    ---  ----------  ----------  ------------  ---------------------------
       1          50  4294967295  connected     Loopback Pseudo-Interface 1
    11          10        1500  connected     Local Area Connection      

    11: <=Keep it in mind

    Next run this command:

                 C:\Users\Administrator>netsh interface ipv4 set interface 11 dadtransmits=0 store=persistent      

    Next, enter
    Run > services.msc > disable DHCP Client service

    Final, restart your server.

    Good Luck.

    This solution is posted my Mr lyngtinh and its works for me. Hopes it work for you :)

    lyngtinh.blogspot.com

    • Zaproponowany jako odpowiedź przez saravanan yuvaraj piątek, 30 września 2016 21:03
    sobota, 16 stycznia 2016 11:58
  • In case someone else runs across this...the problem might not be that Autoconfiguration is enabled, but that the assigned IP address is in use. [...]

    Awesome information! Thanks a lot!
    wtorek, 15 marca 2016 14:38
  • Nice!  This worked for me.

    Thanks, sir!

    poniedziałek, 11 lipca 2016 23:56
  • Thanks! That was my problem too: duplicate IP address already in use
    piątek, 29 lipca 2016 09:55
  • In case someone else runs across this...the problem might not be that Autoconfiguration is enabled, but that the assigned IP address is in use.  I had the same issue & tried the registry key, but still couldn't ping my gateway - but sure enough checked in DNS & the IP assigned by VMM was in use and was being actively used.  Found an old IP that was free, set that as the server's IP address and the server's working just fine now.

    THANKS... solved mine ;)
    poniedziałek, 1 sierpnia 2016 11:54
  • Thank you, my issue resolved as you described.
    poniedziałek, 10 października 2016 07:41
  • could you make it even more difficult? like put you left hand on your right heel while you have your left hand on you machine gun trigger and by nose type in keyboard "I love microsoft"... or such?
    środa, 14 grudnia 2016 15:03
  • Doh me!

    I was connecting by PowerVault (default ip address 192.168.20.128) to my server so I was using 192.168.20.128 as the nic ip address. NOT! The nic ip address could be anything but 192.168.20.128 so now it works! I used 192.168.20.1 on the nic BTW.

    czwartek, 20 kwietnia 2017 15:19
  • Above steps fixed my issue. But not sure which one actually is the fix, whether setting interface dadtransmits or disabling DHCP. I did both restarted the server and it worked.

    Best Regards, Jawad Qazi http://about.me/jawad.qazi

    wtorek, 25 kwietnia 2017 07:31
  • Thank you for this.

    One of my Virtual Machine assigned 'autoconfiguration ipv4 address as preferred' and IPV4 as duplicate. Ideally, it should be IPV4 as preffered address.

    I tried above commands and it worked. After reboot, IPV4 becomes preffered address and autoconfiguration IPv4 removed from ouotput of Ipconfig /All.

    Thank you!!!

    Sudhir

    piątek, 16 czerwca 2017 10:14
  • Yasaar's solution works fine for me !

    Thanks

    wtorek, 20 czerwca 2017 14:36
  • WAIT... FIRST TRY Change IPv4 Address (static). 

    in many cases it happens because of old IP address conflict by another device.

    - if nothing happen then .. open the registry and start work.

    poniedziałek, 10 lipca 2017 18:19
  • I just worked through a similar issue. I VM server was moved to a different IP, and somewhere in the process the NIC settings had gotten lost. After logging in Locally and entering the new settings, it would appear to take them, but then immediately assign a different IP.

    I came across the following info from a colleague:

    When removing a network driver using a vendor-provided uninstallation program or through Device Manager, previously entered static IP address information may not be removed correctly from the registry. After reinstalling the network driver and reentering the same static IP address, the presence of previous registry information prevents the newly entered address information from being saved correctly.

    Resolution

    Once the machine is experiencing this problem, the static IP address, Subnet mask, and Default gateway must be reentered TWICE in order for the values to be saved correctly.

    - Open the Local Area Connection / Internet Protocol Version 4 (TCP/IPv4) Properties dialog, and select "Obtain an IP address automatically", and choose OK.  From the Local Area Connection Properties dialog, choose OK

    - Reenter the Local Area Connection / Internet Protocol Version 4 (TCP/IPv4) Properties dialog, and select "Use the following IP address"

    - Perform the first two steps AGAIN, even though the IP address appears to be displaying properly.

    *or*

    - Open a command prompt under the administrator context and run the following command TWICE, using the desired static address information. For example:

    netsh interface ipv4 set address "Local Area Connection" static 10.0.0.55 255.0.0.0 10.0.0.1

    Note: This first command may return an error "Object already exists"

    netsh interface ipv4 set address "Local Area Connection" static 10.0.0.55 255.0.0.0 10.0.0.1

    Note: This command should succeed with no errors

     

    Sure enough I did it the simple way using the GUI method, reset it to DHCP, then re-entered the IP info and VOILA! It suddenly worked fine.

    piątek, 22 września 2017 19:46
  • Yes this is working for me
    piątek, 5 stycznia 2018 04:40
  • I've had this before, shows autoconfig yes and prefers the 169 address even though you've statically assigned it.

    Server manager shows "multiple addresses"

    I've found its because of a IP conflict somewhere.  try a different static ip, bet it works.

    piątek, 16 marca 2018 15:48
  • This is awesome. This saved me many times rather than running around and changing the registry settings.

    Thank you.

    wtorek, 3 lipca 2018 13:58
  • Worked perfect
    czwartek, 19 lipca 2018 21:34
  • In case someone else runs across this...the problem might not be that Autoconfiguration is enabled, but that the assigned IP address is in use.  

     Fixed my issue... Not sure where it is being used in Virtual Box... but, I got it resolved. I can now ping between the two boxes. 
    środa, 7 listopada 2018 17:24
  • I had the exact same problem on a Windows Server 2016 machine.  Even though I had a static IP  address configured, and therefore DHCP wasn't enabled, it still showed that it was getting autoconfigured with an APIPA 169.254.x.x address.

    I added the key with the 0 value, rebooted and this fixed the problem!

    Thanks!!!
    • Zmodyfikowany przez John-ISU piątek, 4 stycznia 2019 22:22
    piątek, 4 stycznia 2019 21:44
  • In case someone else runs across this...the problem might not be that Autoconfiguration is enabled, but that the assigned IP address is in use.  I had the same issue & tried the registry key, but still couldn't ping my gateway - but sure enough checked in DNS & the IP assigned by VMM was in use and was being actively used.  Found an old IP that was free, set that as the server's IP address and the server's working just fine now.

    Ditto!  Disabled the NIC on the machine, did a ping of the assigned IP and got a response. Gave the machine an new IP and *BAM!* everything is good.
    poniedziałek, 14 stycznia 2019 17:00
  • Thank you Yassar, your solution worked for me!
    piątek, 18 stycznia 2019 15:13
  • After migrating DC from KVM to Hyper-V, it has got this error. Whole day wasted to find solution and you my man save my day. If anyone will will have similar problem just use above!!!
    czwartek, 28 lutego 2019 02:49
  • Thanks Steve, that was the problem for me I had a similar problem as described above and just could not figure it out. It would have worked had it not autoconfgured to a different subnet though -.-
    piątek, 1 marca 2019 01:56
  • Thanks Yasaar Baig! I had it in my virtual machine, now it is working :)
    • Zmodyfikowany przez MGJG środa, 6 marca 2019 17:45 name
    środa, 6 marca 2019 17:44
  • One of the worst answers I have ever seen. You will not there are more questions and statements that say really? I didn't see one thank you!
    niedziela, 9 lutego 2020 01:12