none
DTM problem for Legacy driver(non-plug and play driver) RRS feed

  • Pergunta

  •  Hi,

     

    I have a driver that does not support plug and play. It is a Kernel mode driver, and does not service a real device(like a USB device etc).

     

    I test it under Unclassified Category. but failed when run "Plug and Play Driver Test" job. Error message is "Test Error: could not find the device".

     

    I want to know that whether the driver which to be tested must support plug and play ?



    What do i do to pass the Whql test for non-plug and play driver?


    ml
    terça-feira, 3 de fevereiro de 2009 02:18

Respostas

  • This is a bug in this test. this will be fixed in the next release of the kit.
    Errata filter may help you on this issue. their is a Erratum available on Winqual.microsoft.com.



    Filter #: 862 Release Date: 8/15/2007 Expires: 12/31/2009 Type: Erratum
    [Category] Subcategory: Operating System:
    • [Device]  Storage > Adapter or Controller > ATA RAID
    • [Device]  Storage > Adapter or Controller > SAS-RAID
    • [Device]  Storage > Adapter or Controller > SCSI
    • [Device]  Storage > Adapter or Controller > SCSI RAID
    • [Device]  Storage > Adapter or Controller > Serial ATA RAID
    • Windows XP X64
    • Windows Vista Client
    • Windows Vista Client X64
    • Windows XP IA64
    • Windows XP
    • Windows Server 2003
    • Windows Server 2003 IA64
    • Windows Server 2003 X64
    Issue Description:
    When running the Plug and Play driver test against a storage adapter minport driver which uses the storport.sys port driver the surprise removal test may fail with "Device node status not ok: problem code 0". The rebalance test will then fail with "Device Not Found" because the device is no longer appearing in the system. This failure will also occur when testing disks enumerated by a storport minport.
    Resolution Description:
    This filter makes failures of the plug and play driver test in the storage adapter or hard disk drive logo programs acceptable when storport.sys is loaded on the system and the test log has the following failures. In the surprise removal test: "Device node status not ok: problem code 0." In the rebalance test: "Device Not Found."

    WHQL fans.
    • Sugerido como Resposta 3lunModerator terça-feira, 3 de fevereiro de 2009 05:15
    • Marcado como Resposta 3lunModerator terça-feira, 3 de fevereiro de 2009 05:15
    terça-feira, 3 de fevereiro de 2009 05:14
    Moderador

Todas as Respostas

  • This is a bug in this test. this will be fixed in the next release of the kit.
    Errata filter may help you on this issue. their is a Erratum available on Winqual.microsoft.com.



    Filter #: 862 Release Date: 8/15/2007 Expires: 12/31/2009 Type: Erratum
    [Category] Subcategory: Operating System:
    • [Device]  Storage > Adapter or Controller > ATA RAID
    • [Device]  Storage > Adapter or Controller > SAS-RAID
    • [Device]  Storage > Adapter or Controller > SCSI
    • [Device]  Storage > Adapter or Controller > SCSI RAID
    • [Device]  Storage > Adapter or Controller > Serial ATA RAID
    • Windows XP X64
    • Windows Vista Client
    • Windows Vista Client X64
    • Windows XP IA64
    • Windows XP
    • Windows Server 2003
    • Windows Server 2003 IA64
    • Windows Server 2003 X64
    Issue Description:
    When running the Plug and Play driver test against a storage adapter minport driver which uses the storport.sys port driver the surprise removal test may fail with "Device node status not ok: problem code 0". The rebalance test will then fail with "Device Not Found" because the device is no longer appearing in the system. This failure will also occur when testing disks enumerated by a storport minport.
    Resolution Description:
    This filter makes failures of the plug and play driver test in the storage adapter or hard disk drive logo programs acceptable when storport.sys is loaded on the system and the test log has the following failures. In the surprise removal test: "Device node status not ok: problem code 0." In the rebalance test: "Device Not Found."

    WHQL fans.
    • Sugerido como Resposta 3lunModerator terça-feira, 3 de fevereiro de 2009 05:15
    • Marcado como Resposta 3lunModerator terça-feira, 3 de fevereiro de 2009 05:15
    terça-feira, 3 de fevereiro de 2009 05:14
    Moderador
  • where can i download the newest update filters?

     

    if i download the newest update filters, and applyed to DTM Controller, this job will be passed. is that right?


    ml
    terça-feira, 3 de fevereiro de 2009 06:46
  • I have download the newest update filters,and applied to the dtm controller, but "Plug and play driver test" job failed too.

    What should i do?

    Thanks in advance!

    MULIU

    2009\02\03
    ml
    terça-feira, 3 de fevereiro de 2009 11:24
  • " I have a driver that does not support plug and play"?
    If so...
    Try to self-sign your driver.
    WHQL signature only applies to PnP Device(Driver).
    segunda-feira, 16 de março de 2009 06:58