locked
SSRS Connection Issues RRS feed

  • คำถาม

  • Hi,

    Hope someone can help me with an issue I have beem struggling with over the last few days.  I am have installed SSRS 2008 R2 on server running Windows Server 2008 R2 Enterprise.  I have set everything up and now having what appears to be a running copy of SSRS, the problem that I am having is although it says everything is running, when I create a Connection  using "New Data Source" from the main home page, I create the connection with the following settings.

    Name - CagTest

    Enable Data Source Checked

    Windows integrated Sercurity Checked

    I am testing this with my own Windows User Account for now and I have an account on the SQL Server Installation that I am trying to connect to with db0_owner rights.

    When I test the then created connection it says that the connection was created successfuly, I then click apply.

    I next try to create a report to use this connection, I go back to my main SSRS Management Window and click "Report Builder", the wizard loads up and I do the following.

    Click "Table or Matrix Wizard"

    New window appears and I have "Create a dataset" selected and I click Next

    I browse to find the connection that I created earlier and select it, I test the connection and it says everything is fine. I click the Next button to continue with the wizard and I get an unable to connect error even though I have tested everything, when clicking on the details to see what the error is in detail I get the following message

    "You have specified integrated security or credentials in the connection string for the data source, but the data source is configured to use a different credential type. To use the values in the connection string, you must configure the unattended report processing account for the report server."

    Can anyone offer some help, its almost there but not quite and I am fast loosing what little hair I have left :-)

    If I can offer any more information please ask.

    Thanks Phil

     

     

    3 ธันวาคม 2553 8:57

คำตอบ

  • Hi Phil,

    From your description, it seems you used UID and PWD in the connection string, and you also checked the Windows integrated Sercurity.  If I have misunderstood, please don't hesitate to let me know.

    In a matter of fact, if we have configured the data source to use Windows integrated Security, we are not able to use SQL Server Authentication in the connection. Please just use the following connection string:
    Data Source=servername;Initial Catalog=databasename

    If we want to use SQL Server authentication, please follow these steps:

    1. Set the connection string to be: Data Source=servername;Initial Catalog=databasename
    2. Check "Credentials stored securely in the report server", and type the UID and PWD in the username and password textbox.

    For more information, please see:
    Specifying Credential and Connection Information: http://technet.microsoft.com/en-us/library/ms160330(SQL.90).aspx

    If you have any more questions, please feel free to ask.

    Thanks,
    Jin Chen


    Jin Chen - MSFT
    • ทำเครื่องหมายเป็นคำตอบโดย Challen Fu 13 ธันวาคม 2553 1:52
    6 ธันวาคม 2553 9:29

ตอบทั้งหมด