none
Microsoft .NET Framework Setup RRS feed

  • 问题

  • 为什么当我安装Microsoft .NET Framework 的时候,早期版本的Microsoft .NET Framework不会自动UNINSTALL。。我的电脑现在有4个版本的Microsoft .NET Framework。。也就是

    Microsoft .NET Framework 1.1 SP1
    Microsoft .NET Framework 2.0 SP2
    Microsoft .NET Framework 3.0 SP2
    Microsoft .NET Framework 3.0 SP1

    现在如果我再安装Microsoft .NET Framework 4的话,系统又增加多一个版本的Microsoft .NET Framework。。我想请问我需要安装那么多版本的Microsoft .NET Framework 吗?

    2010年8月21日 12:13

答案

  • 其實你 應該只安裝4就行了 不需要安裝那麼多的  4涵蓋了以前的


    Windows System & Performance 请将已解决的问题标记为“答案”,以便更多的朋友能够方便的找到问题解决方案。
    • 已标记为答案 小东瓜 2010年8月22日 13:15
    2010年8月21日 14:42
    版主
  • 你好

    對的

    不需要NINSTALL早期版本的Microsoft .NET Framework

    因為可能有其他軟件需要之前版本的.NET FRAMEWORK

     


    Chi
    • 已标记为答案 小东瓜 2010年8月22日 13:15
    2010年8月21日 14:43
  • ..net Framework 只有 3.5 包含了 2.0、3.0、3.5 的所有版本。但是其它的版本,诸如 1.0、1.1、4.0 都是独立的,不包含早期的版本。
     
    具体需要哪些版本取决于你需要运行哪些版本的 .net 程序,可以不用安装全部版本。
     
    如果希望安装所有的版本:
     
    1.0、1.1 及其 SP 需要一个一个地单独安装,它们不是向下包容的关系;
    3.5 with SP1 只需安装一次,安装后即可获得 3.5 SP1、3.5、3.0、2.0 的所有版本;
    4.0 必须单独安装一次,4.0 不包含任何早期版本。
     
    --
    Alexis Zhang
     
    https://mvp.support.microsoft.com/profile/jie
    http://blogs.itecn.net/blogs/alexis
     
    推荐以 NNTP Bridge 桥接新闻组方式访问论坛以获取最佳用户体验。
     
    本帖是回复帖,原帖作者是楼上的 "CK Moy"
     
    为什么当我安装Microsoft .NET Framework 的时候,早期版本的Microsoft .NET Framework不会自动UNINSTALL。。我的电脑现在有4个版本的Microsoft
    ..NET Framework。。也就是
     
     
    • 已标记为答案 小东瓜 2010年8月22日 13:15
    2010年8月22日 0:59
    版主

全部回复

  • 你好

    其實視乎你所使用的軟件 才知道 有沒有需要安裝那麼多的.NET FRAMEWORK..因為

    .NET Framework 4 将与旧的 Framework 版本并行工作。默认情况下,基于早期版本的 Framework 的应用程序将继续在目标版本上运行。 有些軟件是需要某一個先前版本的.NET FRAMEWORK 才可以運作的

    關於.NET4 的資訊可以參考以下URL

    http://www.microsoft.com/downloads/details.aspx?FamilyID=9cfb2d51-5ff4-4491-b0e5-b386f32c0992&displaylang=zh-cn

    Please correct me if my concept is wrong


    Chi
    2010年8月21日 13:19
  • 谢谢。。。如果照你这么说也就是说如果我要安装Microsoft .NET Framework 4的话,我不需去UNINSTALL早期版本的Microsoft .NET Framework咯。。。

    2010年8月21日 14:31
  • 其實你 應該只安裝4就行了 不需要安裝那麼多的  4涵蓋了以前的


    Windows System & Performance 请将已解决的问题标记为“答案”,以便更多的朋友能够方便的找到问题解决方案。
    • 已标记为答案 小东瓜 2010年8月22日 13:15
    2010年8月21日 14:42
    版主
  • 你好

    對的

    不需要NINSTALL早期版本的Microsoft .NET Framework

    因為可能有其他軟件需要之前版本的.NET FRAMEWORK

     


    Chi
    • 已标记为答案 小东瓜 2010年8月22日 13:15
    2010年8月21日 14:43
  • ..net Framework 只有 3.5 包含了 2.0、3.0、3.5 的所有版本。但是其它的版本,诸如 1.0、1.1、4.0 都是独立的,不包含早期的版本。
     
    具体需要哪些版本取决于你需要运行哪些版本的 .net 程序,可以不用安装全部版本。
     
    如果希望安装所有的版本:
     
    1.0、1.1 及其 SP 需要一个一个地单独安装,它们不是向下包容的关系;
    3.5 with SP1 只需安装一次,安装后即可获得 3.5 SP1、3.5、3.0、2.0 的所有版本;
    4.0 必须单独安装一次,4.0 不包含任何早期版本。
     
    --
    Alexis Zhang
     
    https://mvp.support.microsoft.com/profile/jie
    http://blogs.itecn.net/blogs/alexis
     
    推荐以 NNTP Bridge 桥接新闻组方式访问论坛以获取最佳用户体验。
     
    本帖是回复帖,原帖作者是楼上的 "CK Moy"
     
    为什么当我安装Microsoft .NET Framework 的时候,早期版本的Microsoft .NET Framework不会自动UNINSTALL。。我的电脑现在有4个版本的Microsoft
    ..NET Framework。。也就是
     
     
    • 已标记为答案 小东瓜 2010年8月22日 13:15
    2010年8月22日 0:59
    版主