none
the user authentication failed RRS feed

  • 问题

  • 请教各位一个问题:mscrm 配置为IFD模式后使用IOrganizationService.Execute时提示the user authentication failed,请问谁有遇到过,急求答案,谢谢!

    刘祖君

    2013年5月27日 8:02

答案

  • 配置成ADFS后,初始化WebService时的方式如下:

    Uri orgServiceUri = new Uri(CRMServiceUrl + "/XRMServices/2011/Organization.svc");
                ClientCredentials credentials = new ClientCredentials();
                credentials.UserName.UserName = CRMUserName;
                credentials.UserName.Password = CRMUserPassword;
                OrganizationServiceProxy crmServiceProxy = new OrganizationServiceProxy(orgServiceUri, null, credentials, null);
                crmService = (IOrganizationService)crmServiceProxy;


    MSN:shan_zhengyi_jrsc@hotmail.com

    2013年6月5日 2:38

全部回复

  • 配置成ADFS后,初始化WebService时的方式如下:

    Uri orgServiceUri = new Uri(CRMServiceUrl + "/XRMServices/2011/Organization.svc");
                ClientCredentials credentials = new ClientCredentials();
                credentials.UserName.UserName = CRMUserName;
                credentials.UserName.Password = CRMUserPassword;
                OrganizationServiceProxy crmServiceProxy = new OrganizationServiceProxy(orgServiceUri, null, credentials, null);
                crmService = (IOrganizationService)crmServiceProxy;


    MSN:shan_zhengyi_jrsc@hotmail.com

    2013年6月5日 2:38
  • How should we implement with no user name password? I tried with  _Credentials.Windows.ClientCredential = CredentialCache.DefaultNetworkCredentials. this works with Visual studio but when i deployed on IIS it is not working

    Is there any solution to call organization service from the custom web app into default user's context?

    Thanks,

    Jaydeep


    Thanks, Jaydeep

    2013年8月28日 5:41