none
Windows Live Messenger问题:代码80072ee7 RRS feed

  • 问题

  • 我能搜索到的答案,能尝试的方法都尝试过了,没有解决,还请各位高手帮忙!

    我在办公室的Windows Live Messenger登不上去了,办公室网络需要设置HTTP代理才能连接Internet,我设置了之后IE8浏览正常,登录webmessenger.live.cn正常,浏览Hotmail邮箱正常。

    Live Messenger登录时的错误提示是80072ee7,对应的提示是“防火墙阻止您登录”。我去Messenger选项—连接—高级里面按“测试”按钮,它提示正常连接到Windows Live Messenger服务。运行“连接问题疑难解答程序”,程序测试说“主要端口”部分有问题,跟防火墙或者代理的设置有关。

    我从网络上搜了一些解决经验,regsvr32、卸载重装……都试过了,没用。我的同事所处的环境与我一致,他们都能连接,真是怪事,各位专家给指点一下我该怎么办吧,多谢!



    2009年8月28日 1:39

答案

  • 感谢诸位的关注,这个问题在各位的帮助、技术支持的指导和自己的不断尝试下,得到了解决,不过原因还不明确,下面把自己做的步骤列在下面:

    我为此问题做了大量实验,就在收到你的来信之前刚刚试验成功,原因还不明确,我做的变动如下:

    1.在Internet选项—高级—安全部分,

    ·去掉“使用SmartScreen”

    ·去掉“使用SSL 2.0”

    ·勾选“使用TLS 1.0”

    关闭IE。

     

    2.卸载已安装的Live Messenger,以及所有Windows Live组件。删除前要删掉Live Messenger记录的用户信息(用户名和密码)。

     

    3.删除C:\Documents and Settings\<username>\Application Data\Microsoft\MSN Messenger目录。

     

    4.删除C:\Documents and Settings\hqhq-zhengjc\Local Settings\Application Data\Microsoft目录下的Windows Live和Windows Live Contacts两个子目录。

     

    5.安装Live Messenger。

     

    登录成功。

    具体原因我不清楚。希望这个流程能给其他遇到类似问题的用户一个参考。

    • 已标记为答案 pChao XP 2009年9月8日 7:35
    2009年9月8日 7:35

全部回复

  • 还是请先参考以下官方有关80072ee7的解决方法:

    错误 80072ee2 80072efd:无法登录 Windows Live Messenger

    由于 防火墙 (旨在帮助保护计算机免受未经授权的外部访问的一项安全功能。它可以是硬件、软件或两者的组合。) 或代理设置的问题而无法登录。 访问另一个网站,以确认您已连接到 Internet 如果您可以连接到 Internet,请查看您的防火墙设置并调整代理设置:

     检查您的防火墙设置。

    1.                      转到 http://people.live.com Windows Live Hotmail 网站。

    2.                      单击页面顶部附近的 Messenger,然后单击登录到 Messenger (Web)”

    如果您可以从 Web 登录 Messenger,但 Windows Live Messenger 仍然无法访问 Internet,则可能是防火墙阻止了 Windows Live Messenger 您需要将 MSNmsgr.exe 添加到防火墙白名单中。有关详细信息,请参阅您的防火墙文档或网站。

     

     调整 Windows Internet Explorer 代理设置。

    1.                      打开 Windows Internet Explorer

    2.                      工具菜单上,单击“Internet 选项

    3.                      连接选项卡上,单击局域网设置

    4.                      清除自动检测设置复选框。

    5.                      单击确定,然后再次单击确定

    2009年8月28日 6:04
  • 这个指南已经看过,完全照做,没有解决。

    登录到Messenger(Web)没有问题。

    我本机没有安装任何防火墙软件,Windows XP自带的防火墙里面已经把Windows Live Messenger设置为例外。

    自始至终没有选择过“自动监测设置”框。

    以前使用Messenger 14(8064.206)是正常的,登录速度也很快,最近升级到8089.726之后就不行了,再降级到8064.206也不灵了,郁闷。
    2009年8月28日 6:16
  • 补充一些内容,好像是连接日志,我看不懂
    [15:32:29.45] 1640            Messenger:                Zone_Net CHTTPNetworkLayer::Disconnect@02762730: Disconnecting HTTPLayer
    [15:32:29.45] 1640            Messenger:                Zone_Net CConnTestDialog::OnConnectionStateChange recieved state change for id(103) from 8 to 0
    [15:32:29.45] 1640            Messenger:                Zone_Net CHTTPNetworkLayer::SendHttpDataInternal@02762730: (103) >> Posted to URL (0 bytes), hr = 0x0
    http://207.46.125.83/gateway/gateway.dll?Action=poll&SessionID=428403298.865047403
    [15:32:29.68] 1640            Messenger:                Zone_Net CHTTPNetworkLayer::HttpCallback: (103) >> called back with 0 (HTTP:200)
    [15:32:29.68] 1640            Messenger:                Zone_Net CConnTestDialog::OnConnectionStateChange recieved state change for id(103) from 0 to 1
    [15:32:31.25] 1640            Messenger:                Zone_Net CConnTestDialog::OnConnectionStateChange recieved state change for id(103) from 1 to 5
    [15:32:31.28] 1640            Messenger:                Zone_Net CConnTestDialog::OnConnectionStateChange recieved state change for id(103) from 5 to 8
    [15:32:31.28] 1640            Messenger:                Zone_Net CHTTPNetworkLayer::SendHttpDataInternal@02762730: (103) >> Posted to URL (26 bytes), hr = 0x0
    http://messenger.hotmail.com/gateway/gateway.dll?Action=open&Server=NS&IP=messenger.hotmail.com
    [15:32:31.51] 1640            Messenger:                Zone_Net CHTTPNetworkLayer::HttpCallback: (103) >> called back with 0 (HTTP:200)
    [15:32:31.51] 1640            Messenger:                Zone_Net HTTP/1.1 200 OK
    Proxy-Connection: Keep-Alive
    Connection: Keep-Alive
    Content-Length: 14
    Via: 1.1 PDCCBPROX02
    Date: Fri, 28 Aug 2009 07:32:56 GMT
    Content-Type: application/x-msn-messenger
    X-MSN-Messenger: SessionID=2107676026.881673168; GW-IP=207.46.125.83
    X-MSN-Host: BY2MSG4030113.gateway.edge.messenger.live.com
    X-MSNSERVER: BY2MSG4030113

    2009年8月28日 7:36
  • 另外,降级到8.5.1302.1018可以正常登录。
    盼望各位能人尽力帮忙分析一下,多谢!
    2009年8月28日 7:51
  • 你好,是不是防火墙挡住了端口啦。
    jon.valett@gmail.com
    2009年8月28日 10:11
    版主
  • 前面说啦,本机没有安装任何第三方防火墙,Windows自带的那个已经是“例外”项目了;我和同事所处的网络环境完全一样,同事可以正常登录。
    2009年8月31日 2:18
  • 你好!
         应该是IE设置问题,你参考同事的设置,重新设置一下IE的代理!
    周雪峰
    2009年8月31日 5:14
    版主
  • 这个我也对过了,真是完全一样,仔细核对过每个空白、每个对勾。
    2009年8月31日 5:55
  • 打开Windows Live Messenger,依次打开,工具---选项----连接----高级设置,检查这里的设置和他们是否一致.
    2009年8月31日 6:00
  • 你是gateway 笔记本  原装系统?  装了杀毒软件没?


    聚信与共 ,创赢未来 微软中文技术论坛
    2009年8月31日 6:01
    版主
  • 完全一样。因为我们单位用ISA Server做HTTP代理,并且跟域用户结合在一起,我们在Internet选项里只要指定代理服务器地址和端口即可,IE浏览不需要输入代理服务器的用户名、密码。

    在Live Messenger里面都不用输入代理服务器信息,它好像是自己引用的Internet选项里面的参数,只有地址和端口,代理用户名和密码都是空白。跟同事的比较了,都一样。
    2009年8月31日 6:03
  • 不是Gateway笔记本,是Lenovo台式机,Windows XP SP3 CHS,有杀毒软件,PC-Cillin 8.0 SP1,这个只有防杀病毒的功能,没有防火墙功能。
    2009年8月31日 6:05
  • 把PC-Cillin 8.0 SP1卸载掉!
    周雪峰
    2009年8月31日 6:23
    版主
  • 1.其他同事也运行这个,这是单位统一安装的
    2.我在本版提问前,因为看过官方帮助,已经尝试在卸载PC-Cillin之后安装、登录Live Messenger,结果问题没有解决。
    2009年8月31日 6:25
  • 你好!
         联系一下Live的客服人员,他们会在24小时之内回复你的,具体流程可以参考:
    http://help.cn.msn.com/cs.html
    周雪峰
    2009年8月31日 10:54
    版主
  • 把PC-Cillin 8.0 SP1卸载掉!
    聚信与共 ,创赢未来 微软中文技术论坛
    2009年8月31日 11:08
    版主
  • 感谢诸位的关注,这个问题在各位的帮助、技术支持的指导和自己的不断尝试下,得到了解决,不过原因还不明确,下面把自己做的步骤列在下面:

    我为此问题做了大量实验,就在收到你的来信之前刚刚试验成功,原因还不明确,我做的变动如下:

    1.在Internet选项—高级—安全部分,

    ·去掉“使用SmartScreen”

    ·去掉“使用SSL 2.0”

    ·勾选“使用TLS 1.0”

    关闭IE。

     

    2.卸载已安装的Live Messenger,以及所有Windows Live组件。删除前要删掉Live Messenger记录的用户信息(用户名和密码)。

     

    3.删除C:\Documents and Settings\<username>\Application Data\Microsoft\MSN Messenger目录。

     

    4.删除C:\Documents and Settings\hqhq-zhengjc\Local Settings\Application Data\Microsoft目录下的Windows Live和Windows Live Contacts两个子目录。

     

    5.安装Live Messenger。

     

    登录成功。

    具体原因我不清楚。希望这个流程能给其他遇到类似问题的用户一个参考。

    • 已标记为答案 pChao XP 2009年9月8日 7:35
    2009年9月8日 7:35
  • 感谢pChao XP分享的解决方案啊!
    周雪峰
    2009年9月8日 10:37
    版主
  • 点开始--运行:regsvr32 %windir%\system32\msxml3.dll   基本上就OK
    • 已建议为答案 感谢 2009年12月16日 1:47
    2009年10月12日 0:05
  • 点开始--运行:regsvr32 %windir%\system32\msxml3.dll   基本上就OK

          我也碰到楼主的问题,按微软官方的建议、楼主的做法都没能解决问题,但是您这个解决方法却很有效,谢谢!
    2009年12月16日 1:48