none
Windows Server 2003 企业版 sp2 蓝屏 RRS feed

  • 问题

  • 运行一个月左右后,出现蓝屏现象,

    重启之后正常运行。之后又出现过一次,提示信息一样。请帮忙判断问题出现在哪里?万分感谢!

    信息:


    Microsoft (R) Windows Debugger Version 6.11.0001.404 X86
    Copyright (c) Microsoft Corporation. All rights reserved.


    Loading Dump File [J:\Mini122712-01.dmp]
    Mini Kernel Dump File: Only registers and stack trace are available

    Symbol search path is: *** Invalid ***
    ****************************************************************************
    * Symbol loading may be unreliable without a symbol search path.           *
    * Use .symfix to have the debugger choose a symbol path.                   *
    * After setting your symbol path, use .reload to refresh symbol locations. *
    ****************************************************************************
    Executable search path is:
    *********************************************************************
    * Symbols can not be loaded because symbol path is not initialized. *
    *                                                                   *
    * The Symbol Path can be set by:                                    *
    *   using the _NT_SYMBOL_PATH environment variable.                 *
    *   using the -y <symbol_path> argument when starting the debugger. *
    *   using .sympath and .sympath+                                    *
    *********************************************************************
    Unable to load image \WINDOWS\system32\ntkrnlpa.exe, Win32 error 0n2
    *** WARNING: Unable to verify timestamp for ntkrnlpa.exe
    *** ERROR: Module load completed but symbols could not be loaded for ntkrnlpa.exe
    Windows Server 2003 Kernel Version 3790 (Service Pack 2) MP (4 procs) Free x86 compatible
    Product: Server, suite: Enterprise TerminalServer SingleUserTS
    Machine Name:
    Kernel base = 0x80800000 PsLoadedModuleList = 0x808a6ea8
    Debug session time: Thu Dec 27 16:39:17.140 2012 (GMT+8)
    System Uptime: 3 days 15:32:40.194
    *********************************************************************
    * Symbols can not be loaded because symbol path is not initialized. *
    *                                                                   *
    * The Symbol Path can be set by:                                    *
    *   using the _NT_SYMBOL_PATH environment variable.                 *
    *   using the -y <symbol_path> argument when starting the debugger. *
    *   using .sympath and .sympath+                                    *
    *********************************************************************
    Unable to load image \WINDOWS\system32\ntkrnlpa.exe, Win32 error 0n2
    *** WARNING: Unable to verify timestamp for ntkrnlpa.exe
    *** ERROR: Module load completed but symbols could not be loaded for ntkrnlpa.exe
    Loading Kernel Symbols
    .............................................WARNING: __ overlaps fltMgr
    WARNING: __ overlaps CLASSPNP
    WARNING: __ overlaps SCSIPORT
    WARNING: __ overlaps MegaSR
    WARNING: __ overlaps volsnap
    WARNING: __ overlaps dmio
    WARNING: __ overlaps ftdisk
    WARNING: __ overlaps pci
    WARNING: __ overlaps ACPI
    WARNING: __ overlaps WMILIB
    WARNING: __ overlaps isapnp
    WARNING: __ overlaps MountMgr
    WARNING: __ overlaps PartMgr
    WARNING: __ overlaps disk
    WARNING: __ overlaps Dfs
    WARNING: __ overlaps crcdisk
    WARNING: __ overlaps watchdog
    WARNING: __ overlaps imapi
    WARNING: __ overlaps intelppm
    WARNING: __ overlaps serenum
    WARNING: __ overlaps kdcom
    WARNING: __ overlaps BOOTVID
    WARNING: __ overlaps dmload
    WARNING: __ overlaps usbuhci
    WARNING: __ overlaps usbehci
    WARNING: __ overlaps fsvga

    Loading User Symbols
    Loading unloaded module list
    ..............
    *******************************************************************************
    *                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    *******************************************************************************

    Use !analyze -v to get detailed debugging information.

    BugCheck D1, {0, d0000002, 8, 0}

    ***** Kernel symbols are WRONG. Please fix symbols to do analysis.

    *************************************************************************
    ***                                                                   ***
    ***                                                                   ***
    ***    Your debugger is not using the correct symbols                 ***
    ***                                                                   ***
    ***    In order for this command to work properly, your symbol path   ***
    ***    must point to .pdb files that have full type information.      ***
    ***                                                                   ***
    ***    Certain .pdb files (such as the public OS symbols) do not      ***
    ***    contain the required information.  Contact the group that      ***
    ***    provided you with these symbols if you need this command to    ***
    ***    work.                                                          ***
    ***                                                                   ***
    ***    Type referenced: nt!_KPRCB                                     ***
    ***                                                                   ***
    *************************************************************************
    *************************************************************************
    ***                                                                   ***
    ***                                                                   ***
    ***    Your debugger is not using the correct symbols                 ***
    ***                                                                   ***
    ***    In order for this command to work properly, your symbol path   ***
    ***    must point to .pdb files that have full type information.      ***
    ***                                                                   ***
    ***    Certain .pdb files (such as the public OS symbols) do not      ***
    ***    contain the required information.  Contact the group that      ***
    ***    provided you with these symbols if you need this command to    ***
    ***    work.                                                          ***
    ***                                                                   ***
    ***    Type referenced: nt!_KPRCB                                     ***
    ***                                                                   ***
    *************************************************************************
    *************************************************************************
    ***                                                                   ***
    ***                                                                   ***
    ***    Your debugger is not using the correct symbols                 ***
    ***                                                                   ***
    ***    In order for this command to work properly, your symbol path   ***
    ***    must point to .pdb files that have full type information.      ***
    ***                                                                   ***
    ***    Certain .pdb files (such as the public OS symbols) do not      ***
    ***    contain the required information.  Contact the group that      ***
    ***    provided you with these symbols if you need this command to    ***
    ***    work.                                                          ***
    ***                                                                   ***
    ***    Type referenced: nt!_KPRCB                                     ***
    ***                                                                   ***
    *************************************************************************
    *********************************************************************
    * Symbols can not be loaded because symbol path is not initialized. *
    *                                                                   *
    * The Symbol Path can be set by:                                    *
    *   using the _NT_SYMBOL_PATH environment variable.                 *
    *   using the -y <symbol_path> argument when starting the debugger. *
    *   using .sympath and .sympath+                                    *
    *********************************************************************
    *********************************************************************
    * Symbols can not be loaded because symbol path is not initialized. *
    *                                                                   *
    * The Symbol Path can be set by:                                    *
    *   using the _NT_SYMBOL_PATH environment variable.                 *
    *   using the -y <symbol_path> argument when starting the debugger. *
    *   using .sympath and .sympath+                                    *
    *********************************************************************
    Probably caused by : ntkrnlpa.exe ( nt+8c963 )

    Followup: MachineOwner
    ---------

     

    2013年1月4日 15:14

答案

  • 您好!

    由于对于蓝屏问题进行排错的步骤比较复杂,很可能需要分析dump文件,我们无法在论坛中为您提供技术支持。为了让您的问题得到及时解决,我建议您使用微软为正版用户提供的8008203800技术支持专线,以便于更好的沟通和交流。以下我提供一些建议,仅供您参考:

    1. 我建议您尝试一次Clean Boot,如果启动的程序太多,这使系统资源消耗殆尽,使个别程序需要的数据在内存或虚拟内存中找不到,也会出现异常错误。

    Clean Boot具体步骤:

    a. 运行MSCONFIG

    b. 在常规下选择 选择性启动。

    c. 然后清除Process System.ini File, Process Win.ini FileLoad Startup Items 的复选框,但是保留使用原始Boot.ini

    d. 在服务下,先点隐藏所有windows 服务,然后选择 disable all

    e. 然后重新启动。观察问题是否依旧发生。

    2. 有些应用程序需调用特定版本的动态链接库DLL,如果在安装软件时,旧版本的DLL覆盖了新版本的DLL,或者删除应用程序时,误删了有用的DLL文件,就可能使上述调用失败,从而出现“蓝屏”。不妨重新安装试一试。如果安装了新的硬件常常出现“蓝屏”,那多半与主板的BIOS或驱动程序太旧有关,以致不能很好支持硬件。如果你的主板支持BIOS升级,应尽快升级到最新版本或安装最新的设备驱动程序。

    3. 硬件故障也会引起的蓝屏问题,建议您先卸载最近安装的硬件,察看问题是否依然存在。

    4. 到以下网站做一个病毒的在线扫描,这些在线扫描有时候是非常有用的,因为机器上的防病毒软件也有可能被感染,但是在线查毒的引擎不会被感染:
    Trend
    http://www.housecall.antivirus.com

    MacAfee:
    http://www.mcafee.com

    感谢您的理解和支持。


    微软一站式示例脚本库: http://blogs.technet.com/b/onescript

    2013年1月7日 8:51
    版主

全部回复

  • 0x000000D1错误表示硬件设备的驱动程序遇到了问题。这个错误一般是因为硬件设备驱动程序存在BUG或安装不正确引起的。请楼主从这方面着手进行检测。

    在IT的路上,You'll never walk alone

    2013年1月5日 1:54
  • 您好!

    由于对于蓝屏问题进行排错的步骤比较复杂,很可能需要分析dump文件,我们无法在论坛中为您提供技术支持。为了让您的问题得到及时解决,我建议您使用微软为正版用户提供的8008203800技术支持专线,以便于更好的沟通和交流。以下我提供一些建议,仅供您参考:

    1. 我建议您尝试一次Clean Boot,如果启动的程序太多,这使系统资源消耗殆尽,使个别程序需要的数据在内存或虚拟内存中找不到,也会出现异常错误。

    Clean Boot具体步骤:

    a. 运行MSCONFIG

    b. 在常规下选择 选择性启动。

    c. 然后清除Process System.ini File, Process Win.ini FileLoad Startup Items 的复选框,但是保留使用原始Boot.ini

    d. 在服务下,先点隐藏所有windows 服务,然后选择 disable all

    e. 然后重新启动。观察问题是否依旧发生。

    2. 有些应用程序需调用特定版本的动态链接库DLL,如果在安装软件时,旧版本的DLL覆盖了新版本的DLL,或者删除应用程序时,误删了有用的DLL文件,就可能使上述调用失败,从而出现“蓝屏”。不妨重新安装试一试。如果安装了新的硬件常常出现“蓝屏”,那多半与主板的BIOS或驱动程序太旧有关,以致不能很好支持硬件。如果你的主板支持BIOS升级,应尽快升级到最新版本或安装最新的设备驱动程序。

    3. 硬件故障也会引起的蓝屏问题,建议您先卸载最近安装的硬件,察看问题是否依然存在。

    4. 到以下网站做一个病毒的在线扫描,这些在线扫描有时候是非常有用的,因为机器上的防病毒软件也有可能被感染,但是在线查毒的引擎不会被感染:
    Trend
    http://www.housecall.antivirus.com

    MacAfee:
    http://www.mcafee.com

    感谢您的理解和支持。


    微软一站式示例脚本库: http://blogs.technet.com/b/onescript

    2013年1月7日 8:51
    版主