none
IIS7.5的ApplicationPoolIdentity用户权限疑问 RRS feed

  • 问题

  • 请教个问题:

    第一个现象:

    发现一个这样的现象,就是新建一个站点后,把该站点根目录的从父亲项继承权限的属性去掉,并且配置system组完全控制,administrators组完全控制,users组完全控制,这样就和不去掉父项继承的时候完全一样。不过这是站点应用程序池启动失败;然后怀疑是applicationpoolidentity权限的问题,通过iis apppool\站点标示名称 的方式添加站点标示用户到站点根目录,并赋予完全控制的权限,这样站点应用程序池启动就成功了。

    第二个现象:

    在新建站点前,先把将要作为站点根目录的目录从父亲项继承权限的属性去掉,并且配置system组完全控制,administrators组完全控制,users组完全控制,这样就和不去掉父项继承的时候完全一样。然后使用该目录作为根目录新建一个站点,该站点的应用程序池启动成功。

    疑问:

    1. 为什么先去掉从父项继承属性,然后再建站点,applicationpoolidentity权限就没有问题,站点应用程序池就可以启动成功那?

    2. applicationpoolidentity用户的权限是如何和目录权限联系起来的那,在不更改父项继承权限的情况下,我们默认看不到该用户,但是站点同样可以正常启动。

    2013年5月31日 8:10

全部回复

  • 你的这个现象:"新建一个站点后,把该站点根目录的从父亲项继承权限的属性去掉,并且配置system组完全控制,administrators组完全控制,users组完全控制,这样就和不去掉父项继承的时候完全一样。不过这是站点应用程序池启动失败"

    在我这里无法重现,我这里实测下来,站点和应用程序池都能正常停启!

    2013年5月31日 9:21
  • 你的这个现象:"新建一个站点后,把该站点根目录的从父亲项继承权限的属性去掉,并且配置system组完全控制,administrators组完全控制,users组完全控制,这样就和不去掉父项继承的时候完全一样。不过这是站点应用程序池启动失败"

    在我这里无法重现,我这里实测下来,站点和应用程序池都能正常停启!


    我这测试的时候,显示是web站点和应用程序池都起来了,不过访问应用程序池的应用的时候失败了
    2013年5月31日 10:32
  • 哎,那么你首次的描述有点坑爹啊。。。写的就是 "应用程序池启动失败"。。。

    而且,你现在的描述依然坑爹:"不过访问应用程序池的应用的时候失败了",这里的 "失败" 一词,可以被理解为很多含义。你觉得你这么描述问题,人家怎么帮你分析?

    赶紧补补吧。搞技术问题,请先把表达练好!感觉自己表达不清的话,上图或Log示意。

    2013年5月31日 13:05
  • 哎,那么你首次的描述有点坑爹啊。。。写的就是 "应用程序池启动失败"。。。

    而且,你现在的描述依然坑爹:"不过访问应用程序池的应用的时候失败了",这里的 "失败" 一词,可以被理解为很多含义。你觉得你这么描述问题,人家怎么帮你分析?

    赶紧补补吧。搞技术问题,请先把表达练好!感觉自己表达不清的话,上图或Log示意。


    嘴怎么这么脏啊,有什么说什么,垃圾
    2013年6月4日 1:36
  • 做技术的,说话就这么直接,你看看你第一次的描述和第二次的追述,你不觉得你在忽悠帮你的人吗?

    把问题陈述精准,那么帮你的人也会少走弯路少浪费时间。

    论坛就应该是这样的,文字毕竟不像电话沟通那么快捷。


    Technical problem is never a problem.

    2013年6月4日 2:23
  • 我描述的问题确实有点模糊,需要描述的清楚些;不过我感觉大家说的时候还是尽量不要这么说,谁听到这样都不好受。

    2013年6月4日 3:00
  • 哈哈,那你重新描述一下你的问题吧。

    Technical problem is never a problem.

    2013年6月4日 8:18