none
MDT 2012 Update 1+ WDS部署操作系统issues:A connection to the deployment share(\\主机FQDN\Deploymentshare$)could not be made. RRS feed

  • 问题

  • 请问微软的各位专家:

    我正通过WDS(Windows Server 2008 R2 企业版)+MDT 2012 Update 1测试客户端部署操作系统。

    客户端计算机启动之后,正常地从 Lite Touch PE (x86)启动,但提示如下图所示错误。我通过测试,发现客户端计算机到 WDS+MDT服务器的IP通讯没有问题,并且对于\\主机FQDN\Deploymentshare$我已添加了everyone 可读权限。

    尽管如此,但仍然提示Invalid Credentials,但并没有跳出任何窗口让我重新输入用户凭据。我应该在何处修改所谓的用户凭据?

    另:WDS+MDT 服务器采用的是Windows Server 2008 R2 Enterprise 评估版,是否有影响。




    • 已编辑 Long Bo 2012年9月16日 3:35
    2012年9月15日 13:47

答案

全部回复

  • 为了验证问题所在,后来我在MDT控制台中删除了Deployment share,然后再新建Deployment share,并重新设置了此共享文件夹的权限,如下图所示。

    客户端启动正常引导进启动之后,提示输入凭据,我就输入了域管理员凭据,但依然提示 A connection to the Deployment share (\\WDS.reascend.com\DeploymentShare$)could not be made. Connection OK. Possible cause:invalid credentials.”



    • 已编辑 Long Bo 2012年9月15日 15:04
    2012年9月15日 13:50
  • 已经通过net use 命令 测试了到\\wds.reascend.com\deploymentshare\ 的连接,显示如图

    2012年9月17日 4:37
  • 您好! 

    根据我的研究,您提供的报错信息,我们建议您先根据以下文章中的步骤排错:

    http://social.technet.microsoft.com/Forums/en-US/mdt/thread/9cf9208e-7218-441d-a632-9a120abe2e7d

    希望我的回答对您有所帮助,如果您还有什么问题,请您再和我们联系。


    如果您对我们的论坛在线支持服务有任何的意见或建议,请通过邮件告诉我们。
    Description: Description: TechNet 论坛好帮手立刻免费下载  TechNet 论坛好帮手

    2012年9月17日 5:12
    版主
  • 文章已看,感谢您的回复。

    我已对照您提供的文章,进行了如下确认:

    1、网络适配器驱动程序驱动无问题,在PE模式下,客户端计算机的网络适配器已经被成功识别,并且已通过DHCP服务器获取了IP地址、DNS服务器、网关等配置。

    2、Deployment Share也已经完全更新,并且在WDS中重新加载了已更新的Lite Touch PE x86 和 x64 启动镜像。

    BTW:为了测试是否仅仅是这一台客户端计算机的个案,我在客户端计算机所在网络中搭建了一台Hyper-V虚拟机,Hyper-V虚拟机选择的“旧版网络适配器”,连接到“外部”网络,虚拟机开机后,从网络正常启动,加载PE过程无误,进行到同样的地方时,仍然提示:

    Connection OK.Possible Cause:Invalid Credentials.

    仍然不甘心,再继续将MDT Deployment Share 属性中的Network (UNC)Path以及bootstrap.ini中的DeployRoot=字段 改成服务器的IP地址。依然出现同样问题。

    顺便再提供一些额外现象以供判断:

    1、单纯通过WDS抓取的Windows 7安装光盘中的 Boot.wim生成启动镜像、抓取install.wim生成安装镜像,然后通过启动客户端计算机,在输入了正确的凭据之后,可以访问WDS共享文件夹RemoteInstall,并且能够完成整个网络安装过程。

    2、仅仅是通过MDT2012 Update 1 创建的Lite Touch PE启动客户端计算机之后,会出现无法访问 DeploymentShare的Invalid Credential错误提示。

    2012年9月17日 8:58

    • 已编辑 Long Bo 2012年9月17日 9:01
    2012年9月17日 8:59
  • 为了更好的确定问题所在,我上传了许多图片。

    另外,提供一些额外信息:

    我的WDS.reascend.com这台Windows 部署服务器,是一台搭建Hyper-V之上的虚拟机,安装的是Windows Server 2008 R2 Enterprise 评估版+WDS服务+MDT2012 Update 1+Windows Automated Installation Tookit。

    虚拟机的宿主主机是Windows Server 2008 R2 Enterprise 正式版(已正版激活)。

    2012年9月17日 10:23
  • 我注意到你当前的网络环境是夸子网了?!

    另外,在出现无效验证提示后,通过cmd使用net use是可以连接wds的?如你上图所示,在cmd下可以连接而litetouch向导不行?


    如果您的问题得到解答,请进行标注。http://goxia.maytide.net

    2012年9月17日 15:51
    版主
  • 是的,客户端和WDS服务器不在同一子网,两个子网之间可以正常的进行IP通讯。公司比较大,所以客户端划分了若干个子网,服务器放在另一个子网,各个子网之间都可以正常IP通讯。

    子网间路由器上配置了DHCP中继,因此客户端计算可以获取DHCP分配的地址。

    出现无效验证提示后,通过net use 可以连接上“\\wds.reascend.com\deployment$”共享,如上面一副相关的截图所示。不仅如此,ping wds.reascend.com 也是可以正常ping通。

    2012年9月18日 1:23
  • 如您所述,网络访问正常,单独验证账号访问也是正常的,那么建议您将bootstrap中的skipbddwelcome设置为no,然后重新启动引导尝试手工验证。

    此外还可以进行如下尝试:

    手动执行net use连接deploypoint然后执行litetouch.vbs检查是否能正常运行。


    如果您的问题得到解答,请进行标注。http://goxia.maytide.net

    2012年9月18日 1:31
    版主
  • bootstrap中的skipbddwelcome设置为no,更新了启动镜像,重新添加到WDS的启动镜像节点中。

    从客户端启动,没有弹出手工验证窗口,依然直接是弹出“……Connection OK. Possible cause:invalid credentials……”错误提示。

    命令行窗口运行net use 去执行litetouch.vbs,我不会,请问该如何输入命令?

    2012年9月18日 2:59
  • net use z: \\wds\deploymentshare$ /user:reascend\administrator

    之后会提示输入验证密码,验证通过后就说明可以访问部署点,之后执行litetouch.vbs

    z:

    cd scripts

    litetouch.vbs


    如果您的问题得到解答,请进行标注。http://goxia.maytide.net

    2012年9月18日 3:02
    版主
  • 挺诡异的,检查一下WDS的安全日志应该有具体的失败原因,贴出来看看。

    能否重新创建一个部署点,以默认方式再进行测试呢?

    我就在昨天也遇到了同样的问题,但我的原因时在同一个网络环境下存在两个近乎相同的AD而导致的验证失败。


    如果您的问题得到解答,请进行标注。http://goxia.maytide.net

    • 已标记为答案 Long Bo 2012年9月18日 3:51
    • 取消答案标记 Long Bo 2012年9月18日 3:51
    2012年9月18日 3:48
    版主
  • 谢谢您的热心解答。

    “能否重新创建一个部署点,以默认方式再进行测试呢?”这个是如何做呢?能否说得详细一些?

    2012年9月18日 3:52
  • 通过MDT控制台,重新创建一个部署点,然后便可直接生成启用映像,尝试引导进行测试,如果还提示无法通过验证,就要从长计议了!

    另外安全日志的记录是怎样的?


    如果您的问题得到解答,请进行标注。http://goxia.maytide.net

    2012年9月18日 3:54
    版主
  • 此问题在bbs.51cto.com论坛得到了zhaonaiqiu 老师的热心帮助,最终解决问题。

    问题解决!

    在此衷心感谢zhaonaiqiu老师对这个问题自始至终的热心解答和帮助!
    这个问题最终解决方法是,将WDS+MDT服务器上的组建 The Windows® Automated Installation Kit (AIK) for Windows® 7 (WAIK for Windows 7)替换为
    Windows Assessment and Deployment Kit (ADK) for Windows® 8之后,在MDT 2012 控制台中“Update Deployment Share”=>“Completely Regenerating the Boot Image”.
    之后,在WDS控制台中删除旧的Lite Touch PE启动镜像,再重新加载新生成的Lite Touch PE 启动镜像。
    客户端计算机正常从网络重启,然后正常地通过访问\\WDS.domain.com\DeploymentShare$凭据验证。 顺利完成整个部署。

    问题解决原帖:

    http://bbs.51cto.com/viewthread.php?tid=957212&extra=&page=1
    • 已标记为答案 Long Bo 2012年9月18日 7:04
    • 已编辑 Long Bo 2012年9月18日 7:05
    2012年9月18日 7:04