none
Net Framework??????? RRS feed

  • 问题

    • 我的是XP家庭版的,请问Net Framework安装哪个版本合适?是安装光盘自带的1.O,还是2.0?或是安装3.5版滴???????知道的说下,谢谢!!!!!!!!!!!!!!!!!!1
    2008年11月17日 7:00

答案

  • 看你的用途了。一般现在大部分程序都是需要.NET2.0或者.NET1.1.

    如果没有什么程序需要的话就不用装了。

    2008年11月17日 7:24
    版主
  • XP光盘不带.net framework的安装文件, 具体安装哪个需要看需求, 如果用1.1的程序就按1.1, 用2.0的程序就安装2.0, 而3.0和3.5其实是2.0的扩展, 一般的程序不容易用到, WPF程序需要用3.0, 就是界面很漂亮的那种, 3.5主要应用是LINQ的程序, 一般安装2.0和1.1大部分软件都能用了.

    2008年11月17日 7:43
  •  

    如果程序不需要 .NET Framework ,不必安装。

     

     

    对于需要 .NET Framework 的软件,安装时都会提示需要哪一版本的 .NET Framework 。

     

    如安装程序需要 .NET Framework 1.1 ,即使已经安装了 Microsoft .NET Framework 3.5 Service Pack 1 版本,也需要另行安装 .NET Framework 1.1 。

     

     

    Microsoft .NET Framework 3.5 Service Pack 1 包括 .NET Framework 2.0 Service Pack 2 和 .NET Framework 3.0 Service Pack 2 。

    2008年11月17日 7:55
  • .net Framework 不是向下兼容的关系,不同版本的 .net Framework 可以共存。看你需要运行的应用程序需要哪个版本就安装哪个版本即可。

    2008年11月17日 8:51
    版主

全部回复

  • 看你的用途了。一般现在大部分程序都是需要.NET2.0或者.NET1.1.

    如果没有什么程序需要的话就不用装了。

    2008年11月17日 7:24
    版主
  • XP光盘不带.net framework的安装文件, 具体安装哪个需要看需求, 如果用1.1的程序就按1.1, 用2.0的程序就安装2.0, 而3.0和3.5其实是2.0的扩展, 一般的程序不容易用到, WPF程序需要用3.0, 就是界面很漂亮的那种, 3.5主要应用是LINQ的程序, 一般安装2.0和1.1大部分软件都能用了.

    2008年11月17日 7:43
  •  

    如果程序不需要 .NET Framework ,不必安装。

     

     

    对于需要 .NET Framework 的软件,安装时都会提示需要哪一版本的 .NET Framework 。

     

    如安装程序需要 .NET Framework 1.1 ,即使已经安装了 Microsoft .NET Framework 3.5 Service Pack 1 版本,也需要另行安装 .NET Framework 1.1 。

     

     

    Microsoft .NET Framework 3.5 Service Pack 1 包括 .NET Framework 2.0 Service Pack 2 和 .NET Framework 3.0 Service Pack 2 。

    2008年11月17日 7:55
  • .net Framework 不是向下兼容的关系,不同版本的 .net Framework 可以共存。看你需要运行的应用程序需要哪个版本就安装哪个版本即可。

    2008年11月17日 8:51
    版主