none
Windows Server 2003 自动更新后 无法正常重启 的奇怪问题 RRS feed

  • 问题

  • 首先系统是Windows Server 2003 ,这个问题同样出现在Windows Server 2003 R2上,不论是虚拟机还是物理机都出现过这个问题。

    我把系统的自动更新设置为 自动下载并安装,当系统安装完成更新时会自动重启,此时系统正常关闭服务,直到出现提示 Windows 正在关机

    这时系统就会一直停留在这个界面,每次都需要我手动到现场晃动一下鼠标,之后过几秒系统就正常关闭让后重启了。

    如果我不到现场去晃一下鼠标(原来显示器是关闭的,晃一下鼠标或者动一下键盘,显示器就亮了),系统就一直停在 Windows 正在关机  的界面无法关闭。

    如果是虚拟机,需要登入到宿主机上,用控制台控制一下虚拟机就可以关闭了。由于这个时候日志服务已经关闭,所以什么日志都没有。

    这个问题目前只在自动安装更新以后出现,如果我手动重启,或者远程重新也不会出现这个问题。

    不知道大家有没有解决办法!(不要关闭自动更新)

    2012年4月15日 6:57

答案

  • 您好!

    根据我的研究,我们建议您先根据以下步骤排错:

    1. 重启服务器,按F8键,选择进入安全模式,测试是否出现该问题。

    2. 请您尝试做一次Clean Boot

    a. 运行MSCONFIG

    b. 在常规下选择 选择性启动

    c. 然后清除Process System.ini File, Process Win.ini FileLoad Startup Items 的复选框,但是保留使用原始Boot.ini

    d. 在服务下,先点隐藏所有windows 服务,然后选择 disable all.

    e. 然后重新启动。观察问题是否依旧发生。

    希望我的回答对您有所帮助,如果您还有什么问题,请您再和我们联系。


    如果您对我们的论坛在线支持服务有任何的意见或建议,请通过邮件告诉我们。
    Description: Description: TechNet 论坛好帮手立刻免费下载  TechNet 论坛好帮手

    2012年4月16日 8:48
    版主
  • 您好!
     
    如果该问题只发生在安装更新后,我们建议您暂时卸载该系统更新,测试问题是否依然存在。

    希望我的回答对您有所帮助,如果有什么不清楚的地方,请您回帖。


    如果您对我们的论坛在线支持服务有任何的意见或建议,请通过邮件告诉我们。
    Description: Description: TechNet 论坛好帮手立刻免费下载  TechNet 论坛好帮手

    2012年5月7日 8:14
    版主

全部回复

  • 您好!

    根据我的研究,我们建议您先根据以下步骤排错:

    1. 重启服务器,按F8键,选择进入安全模式,测试是否出现该问题。

    2. 请您尝试做一次Clean Boot

    a. 运行MSCONFIG

    b. 在常规下选择 选择性启动

    c. 然后清除Process System.ini File, Process Win.ini FileLoad Startup Items 的复选框,但是保留使用原始Boot.ini

    d. 在服务下,先点隐藏所有windows 服务,然后选择 disable all.

    e. 然后重新启动。观察问题是否依旧发生。

    希望我的回答对您有所帮助,如果您还有什么问题,请您再和我们联系。


    如果您对我们的论坛在线支持服务有任何的意见或建议,请通过邮件告诉我们。
    Description: Description: TechNet 论坛好帮手立刻免费下载  TechNet 论坛好帮手

    2012年4月16日 8:48
    版主
  • 请问这个应该如何测试,只会在自动安装更新后发生啊?没分控制!

    2012年4月22日 5:14
  • 您好!
     
    如果该问题只发生在安装更新后,我们建议您暂时卸载该系统更新,测试问题是否依然存在。

    希望我的回答对您有所帮助,如果有什么不清楚的地方,请您回帖。


    如果您对我们的论坛在线支持服务有任何的意见或建议,请通过邮件告诉我们。
    Description: Description: TechNet 论坛好帮手立刻免费下载  TechNet 论坛好帮手

    2012年5月7日 8:14
    版主
  • 不是说哪个更新以后才出现这种情况,是每次更新都出现这种情况,并不是指某一个特定的更新!

    2012年5月7日 13:19