none
RDP文件远程登陆没有保存凭据选项 RRS feed

  • 问题

  • 我在使用RDP远程登陆时下方没有“保存我的凭据”这一个选项框,所以我每次登陆都需要输入密码。请问是何故?是在我的RDS环境里设置吗。此文件是我从另一台win10电脑中拷贝过来的,在那台电脑上有这个选项,但仅仅只有那一台有,拷贝出来的都没有这个选项框。
    2018年1月7日 4:20

全部回复

  • 你好,

    >>此文件是我从另一台win10电脑中拷贝过来的

    请问win10和你实验的机器是否在一个网络环境,是否有域环境。

    我建议你检查一下是否启用了以下的策略,根据你的环境来检查组策略或是本地组策略。

    路径如下,用户配置→管理模板→Windows 组件→远程桌面服务→远程桌面连接客户端

    Best Regards,

    Frank


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    2018年1月8日 7:19
    版主
  • 你好,

    请问回复的信息对你有用么?如果你需要进一步的帮助,请告诉我们。

    Best Regards,

    Frank


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    2018年1月9日 6:36
    版主
  • 我看了一下,两台电脑的本地组策略与组策略中该设置均为未配置。且在同一电脑的几个RDP文件中,也是部分有复选框部分没有。
    2018年1月10日 6:18
  • 你好,

    你可以重建一个rdp连接做测试

    勾选“允许我保存凭据”

    当你的凭据输入一次之后,你可以在控制面板》凭据管理器 看到保存的凭据。在第二步保存的RDP的文件,双击就可以直接连上不需要输入密码了。

    Best Regards,

    Frank


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    2018年1月10日 7:04
    版主
  • 你好,因我方工作需要故RDP文件内包含REMOTE APP程序,且是下放RDP文件,故无法做到你说的这样。请问是什么原因会造成我这个现象呢?
    2018年1月10日 7:50
  • 你好,

    请分别在两台电脑上用 Notepad.exe 打开同样的 .rdp 文件,查看里面的配置是否不一样,具体可以查看跟 credential 相关的配置。

    请问 RemoteApp 的 .rdp 文件是怎么下放的,我建议在 RD Web 网页上直接下载 (使用三方的浏览器)试一下。

    Best Regards,

    Amy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    2018年1月10日 8:10
    版主
  • 两份rdp文件是通过复制黏贴的方式传过去的,经过比较没有区别。另外之前已在RD WEB上下载实验过,也是没有复选框的。谢谢。
    2018年1月10日 8:13
  • 你好,

    请使用管理员运行下面的命令确认一下电脑应用的组策略:

    GPresult /h C:GPresult1.html

    Best Regards,

    Amy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    2018年1月10日 8:15
    版主
  • 已检查过,无任何策略配置。且同一计算机上有的有复选框有的没有,我认为应该不是策略问题。谢谢。
    2018年1月10日 8:22
  • 你好,

    从 RD Web 网页下载的 RemoteApp 文件,右键 Edit 以后如下图所示,请问是否是和我环境中的一样:

    以上为系统的默认行为,下面这个文档有提到 “You cannot override settings that are available in the global deployment settings in RemoteApp Manager. This includes settings such as RD Gateway server settings and common RDP settings“

    Configure Custom RDP Settings

    https://technet.microsoft.com/en-us/library/cc733144%28v=ws.11%29.aspx?f=255&MSPPError=-2147217396

    如果不一样,请把 RDS 环境操作系统和涉及的客户端的操作系统信息提供一下,另外把本机上有和没有复选框的 .rdp 文件的具体配置内容贴出来或者上传到 OneDrive/其它网盘做进一步的分析。

    Best Regards,

    Amy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    2018年1月10日 9:06
    版主
  • 你好,

    请问现在有进展了吗?

    Best Regards,

    Amy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    2018年1月15日 8:07
    版主