none
RSAT 连接问题 RRS feed

  • 问题

  • 请问能否将RSAT的ServerManager.msc连接改为https,虽然http也是加过密的,但希望能改为更安全的 https。我已经成功在WinRM配置了 https,客户端也可以通过powershell的带usessl的new-pssession, enter-pssession建立回话。
    但是就是ServerManager.msc不行,可以通过像dc01.contoso.local:5984连接到自定义的http端口,但就是不知道如何让其连接到服务器的https端口。
    是我设置有问题,还是不支持?
    2014年6月12日 12:26

答案

  • 您好,

    Server Manager并不支持Https

    Server Manager是基于默认的WinRM的设置,如果远程的服务器的WinRM设置被改变了,那Server Manager将无法与远程服务器进行通信。

    Server Manager relies on default WinRM listener settings on the remote servers that you want to manage. If the default authentication mechanism or the WinRM listener port number on a remote server has been changed from default settings, Server Manager cannot communicate with the remote server.

    The following list shows default WinRM listener settings for managing by using Server Manager.

    • The WinRM service is running.
    • A WinRM listener is created to accept HTTP requests through port number 5985.
    • Port number 5985 is enabled in Windows Firewall settings to allow requests through WinRM.
    • Both Kerberos and Negotiate authentication types are enabled.

    The default port number is 5985 for WinRM to communicate with a remote computer.

    For more information about how to configure WinRM listener settings, at a command prompt, type winrm help config, and then press ENTER.

    http://technet.microsoft.com/en-us/library/hh921475.aspx

    谢谢。


    Jeremy Wu

    TechNet Community Support

    2014年6月18日 15:46
    版主