none
用远程连接mstsc服务器后,断开后,用户自动logoff,如何设置不让自动logoff? RRS feed

  • 问题

  • 我已经在组策略里关闭了如下设置,并且执行了gpupdate /force,但是还是会自动logoff,请问我还应该检查什么地方?谢谢!

    图片无法上传,如下:

    组策略-计算机模板下面,找到session time limits文件夹设置

    set time limit for disconnected sessions - disable.

    set time limit for active but idle remote desktop services - disable.

    set time limit for active remote desktop services sessions - disable.

    end session when time limits are reached - disable

    set time limit for logoff of remoteapp sessions - disable.

    请各位建议,谢谢!
    2020年2月22日 4:15

答案

  • Hi Jimmy,

     

    感谢你的反馈,这样看来在你的环境中影响自动log off的是Set time limit for active but idle Remote Desktop Services sessions 这条策略以及对应注册表键值

    当前你可以把删除此条注册表当作是一个workaround,更深层的测试和研究可能需要你的IT一起查看域策略以及本地策略然后一一测试。

     

    此致

    Jenny


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • 已标记为答案 Kimmy Zhu 2020年2月26日 0:39
    2020年2月25日 3:50

全部回复

  • 你好,

    1.你可以通过gpresult 来核查上述组策略是否应用成功。

    2.请假查一下组策略对应的注册表键值是否符合你的设置。

    Policy Setting Name

    Policy Path

    Registry Information

    End session when time limits are reached

    Windows Components\Remote Desktop Services\Remote Desktop Session Host\Session Time Limits

    HKCU\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services!fResetBroken

    Set time limit for disconnected sessions

    Windows Components\Remote Desktop Services\Remote Desktop Session Host\Session Time Limits

    HKCU\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services!MaxDisconnectionTime

    Set time limit for active but idle Remote Desktop Services sessions

    Windows Components\Remote Desktop Services\Remote Desktop Session Host\Session Time Limits

    HKCU\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services!MaxIdleTime

    Set time limit for active Remote Desktop Services sessions

    Windows Components\Remote Desktop Services\Remote Desktop Session Host\Session Time Limits

    HKCU\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services!MaxConnectionTime

    3.检查一下是否有auto logofftask scheduler 设置。

    4.请检查一下eventlog 查看一下与auto logoff 相关的活动轨迹和时间。

     

    此致,

    Jenny


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    2020年2月24日 2:33
  • 你好Jenny,

    我运行了gpresult,看到我们集团组策略有个是Set time limit for active but idle Remote Desktop Services sessions,我在本机组策略禁止了这一项,重启检查注册表还是按照集团域控组策略生效的,按道理应该是本机组策略优先级别高,为何注册表不是按照本机的来的呢?

    另外一个问题是,这个Set time limit for active but idle Remote Desktop Services sessions这项我看解释,是说断开RDP,而不是注销用户,删除了这个注册表,重启后,确实不会自动注销了,功能和解释是不一样的咯。。。 郁闷

    2020年2月24日 2:53
  • Jimmy你好,

    1.域策略优先级应该是高于本地策略的,因为它是在本地策略之后处理的,如果存在冲突,则可以覆盖设置。所以在你的案例中,需要手动修改注册表键值来实现。

     

    2.根据我的理解set time limit for active but idle session 的确是指在超过指定的时间后,远程桌面服务自动断开连接活动但空闲的会话而非注销。

    Time limit下的几个策略中,以下三个涉及到注销用户会话, 或许你可以在检查这几项看看。

    Set time limit for disconnected sessions

    Set time limit for logoff of RemoteApp sessions

    Terminate session when time limits are reached

    https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-server-2008-R2-and-2008/cc753112(v=ws.10)?redirectedfrom=MSDN

     

    此致,

    Jenny


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    2020年2月24日 5:49
  • 非常好,我收藏了!
    2020年2月24日 5:59
  • 你好Jenny,

    由于我看不到集团的组策略设置,只能看到GPresult里关于注册表的设置,如下

                    Folder Id: SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services\fReconnectSame
                    Value:       1, 0, 0, 0
                    State:       Enabled

                    Folder Id: SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services\fResetBroken
                    Value:       1, 0, 0, 0
                    State:       Enabled

                    Folder Id: SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services\MaxDisconnectionTime
                    Value:       160, 187, 13, 0
                    State:       Enabled

    请问上面三个分别对应的组策略的哪项设置,是否和自动logoff有关啊?

    2020年2月25日 1:05
  • Hi Jimmy,

    1.fReconnectSame--->Allow Reconnection from Original Client Only

    但是根据我查找的信息这条组策略是针对citrix 环境的,决定是否只有原始客户端来的会话可以被重新连接。

    (controls whether a different client may be used to resume a disconnected session. Only the original client should be able to resume a session to help prevent session hijacking.)

     

    2.fResetBroken----->End session when time limits are reached 也就是上条回复中的Terminate session when time limits are reached.

    You can use this policy setting to direct Terminal Services to terminate a session (that is, the user is logged off and the session is deleted from the server) after time limits for active or idle sessions are reached. By default, Terminal Services disconnects sessions that reach their time limits.

    If you enable this policy setting, Terminal Services terminates any session that reaches its time-out limit.

    If you disable this policy setting, Terminal Services always disconnects a timed-out session, even if specified otherwise by the server administrator.

     

    由此可见这条注册表键值和对应的组策略是与log off 有关的。你可以尝试修改键值为0试试看。

     

    如果回复对您有所帮助的话,您可以把回复标记为答复。

     

    此致

    Jenny


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    2020年2月25日 1:48
  • Hi Jenny,
    将fResetBroken改成0后,还是会自动logoff,

    2020年2月25日 3:18
  • Hi Jimmy,

     

    感谢你的反馈,这样看来在你的环境中影响自动log off的是Set time limit for active but idle Remote Desktop Services sessions 这条策略以及对应注册表键值

    当前你可以把删除此条注册表当作是一个workaround,更深层的测试和研究可能需要你的IT一起查看域策略以及本地策略然后一一测试。

     

    此致

    Jenny


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • 已标记为答案 Kimmy Zhu 2020年2月26日 0:39
    2020年2月25日 3:50
  • 好的,谢谢!
    2020年2月26日 0:39