none
错误信息显示不正常 RRS feed

  • 问题

  • 类库跟一个网站在一起的。
    类库的错误信息能正常显示出一来,没有问题。
    但在生成网站时,只能显示出来错误,页面行号等是空白的显示不出来。双击也没有反应。不知道怎么回事。
    别的项目都是正常的。
    2009年8月19日 2:52

答案

全部回复

  • 描述问题不是很清楚
    请你再描述清楚一些
    2009年8月19日 2:58
  • 启动调试时提示
    无法启动应用程序"网页地址",系统找不到指定的文件。
    2009年8月19日 3:01
  • 你好!
         你新建一个空白的站点,看看能否启动调试!
    周雪峰
    2009年8月19日 3:18
    版主
  • 提示 “无法启动程序 http://…… 系统找不到指定的文件”的错误,G一下发现原来是我之前安装了IE6绿色版,之后有因为用的是Windows2008 无法使用IE6卸载过后,Vs找不到IE产生的问题,
    解决办法是,修改注册表,如果该节点位置没有该注册表项就手动添加一个吧,内容如下

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths\iexplore.exe]@=”C:\\Program Files\\Internet Explorer\\iexplore.exe”
    如果以上的方法 不能解决的话 用系统盘恢复系统
    2009年8月19日 3:32
  • 错误    9    参数“1”: 无法从“System.Guid”转换为“int”       
    错误    8    与“BLL.User.GetInfo(int)”最匹配的重载方法具有一些无效参数       
    原来的一个项目,我改了底层的类,一些东西找不到了,所以在生成页面时出错。
    对于新的错误,比如我现在在后台没输分号,能提示出来,上面的就提示不出来。
    谢谢两位,我试试看
    2009年8月19日 6:26
  • 我在另一个控制台项目加了这个网站,错误信息也是提示不出来。
    应该跟项目无关。
    2009年8月19日 6:29
  • mldark
    我windows 2003在APP Paths下没有找到iexplore.exe
    不过没关系,我可以附加进程来调试。

    2009年8月19日 6:33
  • 你描述问题 越来越远了 你说清楚你的问题重点是什么
    你不要一会什么无法启动........ 一会不提示了 一会附加进程调式 把我们弄晕了
    2009年8月19日 6:56
  • 你好!

    能否把你的问题整理一下,详细的告诉我们??
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    2009年8月20日 7:41
  • web.config里设置
    <compilation defaultLanguage="c#" debug="true" />
    <customErrors   mode="Off"   />
    即可
    <compilation defaultLanguage="c#" debug="true" />不推荐这么做
    【孟子E章】
    2009年8月20日 12:47
    版主
  • 是不能提示,主要
    不能启动是辅助问题,用来进一步定位问题的。
    不过现在看来无所谓了
    2009年8月21日 3:20
  • web.config
    对于运行时才有效吧
    对于编译没作用吧
    2009年8月21日 3:22
  • http://a-110.cn/a.zip
    我把页面上传到了这里。
    你看一下。


    不知道是不是我本地VS环境问题。
    2009年8月21日 3:38
  • 你的项目 n多错误  文件那么多  我无法测试
    你换个机器试试
    2009年8月21日 4:02
  • http://www.soft000.com/x.jpg
    看图

    我不是要你找错误,不是要你来帮我调试。
    我是说为什么这个错误提示没文件,行号等,双击也没有反应。


    2009年8月21日 5:47
  • 你好,右键错误列表,会出现显示列菜单,可以选择你需要显示的信息。
    jon.valett@gmail.com
    2009年8月21日 6:27
    版主
  • http://www.soft000.com/x.jpg
    看图

    我不是要你找错误,不是要你来帮我调试。
    我是说为什么这个错误提示没文件,行号等,双击也没有反应。



    奇怪了 我点击能找到文件啊 那你的vs问题 了
    2009年8月21日 9:06
  • 是的呀。
    我就是奇怪这一点

    不是我的VS问题,我用的也是微软的VS
    是微软的VS问题。

    我曾把环境重置,但是老样子。
    2009年8月24日 1:49
  • 类库跟一个网站在一起的。
    类库的错误信息能正常显示出一来,没有问题。
    但在生成网站时,只能显示出来错误,页面行号等是空白的显示不出来。双击也没有反应。不知道怎么回事。
    别的项目都是正常的。


    我在另一个控制台项目加了这个网站,错误信息也是提示不出来。
    应该跟项目无关。

    别的项目都是正常,但是惟独这个项目不正常的话,那可能是这个个别的项目引起的。
    以下是一些类似的问题,你可以看一下:
    http://blog.csdn.net/xiaojing5202/archive/2009/01/02/3686990.aspx
    http://topic.csdn.net/u/20071102/17/9705d21e-28b7-49d6-a761-99764ad2c16b.html

    希望对你有所帮助。
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • 已标记为答案 male110 2009年8月24日 6:29
    2009年8月24日 2:20
  • 看了你的链接。
    一,我的项目没有括号之类的,项目名称:Model,Dal,BLL,还有一个网站
    二,目录不深,放在了F:\新建文件侠(2)
    三,错误原是指定的错误显示不出来,就是我对Model里的实体类重命名了,倒至页面里的类错误。
    而别的错误都是正常的。
    在代码里,输入错误的代码绝对能提示。

    只有那几个错误不能提示,好怪。


    对了,我换个目录试试,不会是因为在F:\新建文件侠(2),目录有()这个的原因吧
    2009年8月24日 6:23
  • 当然可以啊,你可以试一下。

    因为我查了一下之后,发觉产生这种原因的确很有多的可能性,现在唯一能稍微确认点的,就是这种情况只发生在你的这个项目里,其他的项目都没问题,所以应该是这个项目引起的。
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    2009年8月24日 6:26
  • 果然是项目所放目录有()的问题
    2009年8月24日 6:29
  • 呵呵,很高兴能帮你解决了这个问题。 :)
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    2009年8月24日 6:31