none
SCCM OSD XP后蓝屏 RRS feed

  • 问题

  • SCCM在虚拟机上抓取了XP的WIM后分发到客户机,客户机重启后会蓝屏。错误代码0x0000007b。 我搜索的结果是说是XP HAL和MASS STORAGE驱动不匹配的原因,请问有人知道具体怎么解决吗? 谢谢!
    Peace&Love
    2009年9月21日 6:26

答案

  • Windows Vista之前的系统,在Prepare之后如果部署到HAL不同的硬件上,就会因为磁盘驱动不同导致找不到磁盘,由此产生7b的stop错误.
    其实使用虚机来抓取WIM是一个很好的思路,避免了硬件驱动对镜像文件的影响.
    不过您需要在部署过程中,使用TS对客户端的驱动进行应用.
    有一篇老外的blog,是根据WMI查询得到机器型号来应用这个驱动的。您可以参考一下。
    我计划写一篇关于此问题的blog,将在不久后发表在blog.itecn.net。欢迎继续探讨。


    Hao Hu
    2009年10月12日 3:35

全部回复

  • 呵呵,你用虚拟机的镜像去安装客户机当然是不行的,驱动当然不匹配了;只能用一台客户机安装后再抓取镜像来用,并且不同品牌的主板也是会引起蓝屏的。

    2009年9月23日 14:36
  • 是可以的,winos.cn里有人成功过,不过写的不详细。 解决了HAL的问题的话,其实是跟那种万能ghost一个道理。 不同主板就蓝屏的话,OSD对硬件种类多的公司就没意义了。

    大致是可以通过集成massstorage驱动包到task sequence里去做的。
    Peace&Love
    2009年9月23日 14:40
  • XP 和以前的时代, 硬件仿真层 HAL 和 块存储 MassStorage 在image 源和目标之间必须兼容才能使用。 这个在 sysprep 和 WinPE的文档中都有详细说明。 也有说明 deploy.cab 压缩包中的另一个工具可以处理这种情况,但是没有继续深入研究,因为根本用不着

    记得当时一些论坛正在测试 Vista 和 Win2008 beta版,说是vista, Win2008 都不再有这些限制,但是后来就没再研究这块,没有做过测试如何具体实现。建议看看新版的 WAIK 的相关文档。


    我个人短期内无暇做这方面研究,还请其它版主,牛人来指点吧,呵呵。
    2009年9月27日 4:55
    版主
  • Windows Vista之前的系统,在Prepare之后如果部署到HAL不同的硬件上,就会因为磁盘驱动不同导致找不到磁盘,由此产生7b的stop错误.
    其实使用虚机来抓取WIM是一个很好的思路,避免了硬件驱动对镜像文件的影响.
    不过您需要在部署过程中,使用TS对客户端的驱动进行应用.
    有一篇老外的blog,是根据WMI查询得到机器型号来应用这个驱动的。您可以参考一下。
    我计划写一篇关于此问题的blog,将在不久后发表在blog.itecn.net。欢迎继续探讨。


    Hao Hu
    2009年10月12日 3:35
  • 有一篇老外的blog,是根据WMI查询得到机器型号来应用这个驱动的。您可以参考一下......

    这个文章在那里,能分享下地址么?
    2009年11月9日 7:26
  • 既然说可以用虚拟机抓取的镜像来部署实际中的电脑,那就应该把详细的具体的内容说下,还有就是解决蓝屏的方法。不要只说能又不说方法,对实际要解决这方面的问题没什么帮助。
    2009年11月30日 4:07
  • http://bbs.winos.cn/thread-81834-1-2.html  我找到了这个帖子,楼上看下吧
    2009年12月6日 15:37