none
Windows Server2008 R2文件共享无法通过IP访问,只能通过主机名访问 RRS feed

  • 问题

  • 您好

    我们有一台Windows Server2008 R2服务器上面有若干个文件夹共享了出来

    今天早上发现客户端PC通过“\\IP”这样的形式无法访问了,提示如下:

    “\\XXXXX无法访问。您可能没有权限使用网络资源。请与这台服务器的管理员联系以查明您是否有访问权限。

    目前没有可用的登录服务器处理登录消息”

    但是使用“\\主机名”这样的形式可以正常访问。之前没有出现过这样的问题。

    现在通过客户端PING服务器的IP地址和主机名都没有问题

    请问这样可能是什么问题导致的,有没有解决方法

    谢谢

    2018年10月8日 3:10

全部回复

  • 追加信息:

    网络通信正常,客户端服务器之间可以互相ping通,防火墙关闭。

    另外最新发现:通过这台有问题的Server2008 R2一个正常的网络共享,显示如下错误。

    "Windows cannot access \\正常地址\" check the spelling of the name....Eooror code: 0x80004005 Unspecified error

    2018年10月8日 6:38
  • 你好,

    谢谢你的问题。

    根据您的描述,您可以通过客户端ping服务器的IP地址和主机名,可以表明您的IP设置没有问题。

    请尝试暂时关闭防火墙和杀毒软件,文件共享的端口一般是139和455,这些端口可能存在被禁用的可能。

    请检查禁用他们之后的结果。

    以下的两个链接存在和您一样的问题,可以参考。

    https://www.techrepublic.com/forums/discussions/cannot-access-shared-folders-by-ip-address-but-i-can-by-name/

    https://social.technet.microsoft.com/Forums/windowsserver/en-US/a4bf3032-b976-48cc-9a25-9e67539cdf39/cannot-access-shared-folders-by-ip-address-but-i-can-by-hostname?forum=winserverfiles

    Best Regards,

    Lee


    Just do it.

    2018年10月8日 6:52
    版主
  • https://blogs.technet.microsoft.com/csstwplatform/2011/03/16/windows-7-0x80004005/

    Windows7访问共享文件夹,出现错误代码: 0x80004005 的解决方案


    Just do it.

    2018年10月8日 6:57
    版主
  • 微软工程师你好,

    谢谢你的迅速回复。

    10月8日当天根据你提供的内容,

    进行了防火墙和杀毒软件的检查,都是出于关闭状态,

    而且通过客户端telnet端口可通,不在在端口禁用问题。

    检查了IPV6也是关闭的。

    另外还尝试了“ Turn on network discovery ”,发现没有效果。

    我尝试重启了一下“LanmanServer”这个服务,惊奇地方发现重启之后问题解决了,可以通过IP地址打开共享文件夹,

    只是可惜过了1分钟之后问题再次出现,最后我们只能采取重启服务器的方法。

    服务器重启之后,问题终于得到解决。

    请问,我们是什么原因导致“LanmanServer”这个服务出现问题的,以后应该如何避免?

    2018年10月18日 6:01
  • 你好,

    服务名称:LanmanServer 
    显示名称:服务器
    描述:支持通过网络为此计算机共享文件,打印和命名管道。如果停止此服务,则这些功能将不可用。如果禁用此服务,则任何明确依赖它的服务都将无法启动。

    可执行文件的路径:C:\ Windows \ system32 \ svchost.exe - k netsvcs

    1. 打开services.msc> server>properties>startuptype>automatic.

    2. 打开注册表编辑器,导航到HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ services \ LanmanServer 找到start键值,双击编辑自动- 2 手动- 3 禁用- 4 自动(延迟启动)

    检查该服务是否为自动启动启动。

    Best Regards,

    Lee


    Just do it.

    2018年10月18日 7:03
    版主
  • 你好,

    请问你的问题已经被解决了吗?如果问题已经被解决了,请记得标记为答案。

    Best Regards,

    Lee


    Just do it.

    2018年10月26日 8:56
    版主
  • 您好!
    由于该帖长时间未有响应。我们将把之前的回复标记为答复。如果您需要我们的继续协助,您可以随时在该帖下回复,同时您可以根据实际情况取消作为答复。
    感谢您的理解与支持。
    Best Regards,
    Lee

    Just do it.

    2018年11月5日 9:31
    版主