none
.net framework 4.5的软件可以在.net framework 4.6下运行吗 RRS feed

  • 问题

  • 服务器是server 2016自带.net framework 4.6,但是软件是在.net framework 4.5下开发的,请问软件可以正常使用吗?谢谢
    2020年1月20日 7:52

全部回复

  • 你好,

    基本是没问题的,根据官网给出的信息,这个向下兼容。

    .NET Framework 4.x 版本是早期版本的就地更新版。 这意味着:
    计算机上只能安装一个版本的 .NET Framework 4.x。
    如果计算机上已安装更高版本,则不能安装 .NET Framework 的早期版本。
    .NET Framework 4.x 版本可用于运行针对 .NET Framework 4.0 到该版本生成的应用程序。 例如,.NET Framework 4.7 可用于运行针对 .NET Framework 4.0-4.7 生成的应用程序。 最新版本(即 .NET Framework 4.8)可用于运行使用从 .NET Framework 4.0 开始的 .NET Framework 的所有版本生成的应用程序。

    https://docs.microsoft.com/zh-cn/dotnet/framework/install/on-windows-10

    如果回答是有帮助的, 请将其标记为答案, 可以帮助其他有相同问题的社区成员, 并快速找到有用的答复。



    针对Windows 2008/2008R2的扩展支持将于2020年结束,之后微软将不再为其提供安全更新。点击此处或扫描二维码获取《在 Azure 上运行 Windows Server 的终极指南》,把握良机完成云迁移并实现业务现代化。


    2020年1月20日 9:49
  • 是可以兼容的朋友!
    2020年1月20日 13:33