none
exchange 2007 re-install IIS problem (Urgent) RRS feed

  • 問題

  • Hello

    本人不小心將exchange 2007 server的IIS剷掉,現在已經重裝返個iis,不係想問係咪仲有其他野要set返?根據http://support.microsoft.com/?scid=kb%3Bzh-tw%3B320202&x=10&y=10 的提議,步驟3-移除並重新安裝exchange client access 2007 伺服器角色中的第三部份﹕"請遵循指示在 2007 [ Exchange 伺服器安裝精靈 ]。 在 [ 選取伺服器角色 ] 頁, 請按一下以清除核取方塊, 用戶端存取角色 及 [ 下一步 ] 。 "是什麼意思?意即要選取那個?還是三個選擇都不要?可否麻煩各位給我一個清晰的提示?謝謝大家?urgent的~~

     

    2008年10月21日 下午 07:50

解答

  • 你好

    經過多日的努力,終於搞掂了~嘗試了很多方法,現在提供一個自己嘗試出來的解決方案

    1. Disable all exchange 2007 services
    2. stop IIS services and in the local computer-->website-->default web site, delete owa, exchweb, oab  component
    3. update the .net framework 1.0 services pack1
    4. remove and reinstall the CAR(in control panel-->add and remove)
    5. Goto administrator tools-->services-->start all exchange 2007 services(regards POP3 and IMAP4 default is manual start up, you need change to auto.)
    6. start IIS and test again.
    2008年10月28日 下午 06:38

所有回覆

  • 您好!

     

    如果您要在運行Exchange 2007 的計算機上重新安裝IIS,您也必須重新安裝Exchange 2007。這是為了恢複鏈接到IIS提供OWA功能和其他Exchange 相關的Web 服務像Availability service。

     

    要刪除IIS並重新安裝IIS和Exchange 2007,大致步驟如下:

     

    1、 刪除IIS。
    2、 重新安裝IIS,然後安裝最新的SP。
    3、 刪除並重新安裝客戶端訪問服務器(CAS)角色。注意,該步驟中只需要刪除CAS 角色,不需要刪除別的角色。
    4、 如果Exchange 服務器配置有郵箱角色的話,重新創建IIS 虛擬目錄來恢複鏈接到Exchange 2007 的角色。

     

    詳細的操作步驟,請參考下面的鏈接:


    How to remove and to reinstall IIS on a computer that is running Exchange Server
    http://support.microsoft.com/kb/320202/en-us

     

    希望對您有所幫助!

     

    Rock Wang 望正茂


     

    2008年10月23日 上午 01:51
    版主
  • 你好

    我根據http://support.microsoft.com/kb/320202/en-us 的指示,但當我去到重新建立 IIS 虛擬目錄來還原與 Exchange 2007 信箱角色連結一項時,就出現以下句子﹕

    [PS] C:\Documents and Settings\Administrator.MAILSERVER>get-owavirtualdirectory
    -server mailserver | ? {$_.OwaVersion -eq "Exchange2003"} | remove-owavirtualdir
    ectory -DomainController MAILSERVER
    WARNING: Outlook Web Access has detected an inconsistency in the Active
    Directory configuration for the following virtual directories. This can happen
    if Outlook Web Access virtual directories were deleted in Internet Services
    Manager. Verify that you have access to the metabase on the servers listed
    below. To correct this inconsistency, run the following command:
    Remove-OwaVirtualDirectory -Identity "Exchange (Default Web Site)". Running
    this command will remove references to these virtual directories from the
    Active Directory directory service."Exchange (Default Web Site)"
    WARNING: Outlook Web Access has detected an inconsistency in the Active
    Directory configuration for the following virtual directories. This can happen
    if Outlook Web Access virtual directories were deleted in Internet Services
    Manager. Verify that you have access to the metabase on the servers listed
    below. To correct this inconsistency, run the following command:
    Remove-OwaVirtualDirectory -Identity "Public (Default Web Site)". Running this
    command will remove references to these virtual directories from the Active
    Directory directory service."Public (Default Web Site)"
    WARNING: Outlook Web Access has detected an inconsistency in the Active
    Directory configuration for the following virtual directories. This can happen
    if Outlook Web Access virtual directories were deleted in Internet Services
    Manager. Verify that you have access to the metabase on the servers listed
    below. To correct this inconsistency, run the following command:
    Remove-OwaVirtualDirectory -Identity "Exadmin (Default Web Site)". Running this
     command will remove references to these virtual directories from the Active
    Directory directory service."Exadmin (Default Web Site)"

     

    而在OWA就出現以下情況,請問有什麼辦法解決?

    Server Error in '/owa' Application.

    Runtime Error

    Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed.

    Details: To enable the details of this specific error message to be viewable on the local server machine, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "RemoteOnly". To enable the details to be viewable on remote machines, please set "mode" to "Off".

    <!-- Web.Config Configuration File -->
    
    <configuration>
        <system.web>
            <customErrors mode="RemoteOnly"/>
        </system.web>
    </configuration>

    Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

    <!-- Web.Config Configuration File -->
    
    <configuration>
        <system.web>
            <customErrors mode="On" defaultRedirect="mycustompage.htm"/>
        </system.web>
    </configuration>

    2008年10月24日 上午 07:29
  • 您好!

     

    您要重新安裝IIS 的Exchange 服務器上有郵箱服務器角色嗎?如果沒有的話,您不需要執行重新創建IIS 虛擬目錄的步驟。

     

    如果有的話,請先刪除所有的OWA虛擬目錄,然後在創建這些目錄,具體的步驟請參考下面的鏈接:

     

    如何刪除 Outlook Web Access 虛擬目錄
    http://technet.microsoft.com/zh-cn/library/aa998589(EXCHG.80).aspx

     

    如何在 Exchange 2007 中創建 Outlook Web Access 虛擬目錄
    http://technet.microsoft.com/zh-cn/library/bb124811(EXCHG.80).aspx

     

    謝謝!

     

    Rock Wang 望正茂

    2008年10月24日 上午 09:14
    版主
  • 你好

    謝謝你的幫忙,可是問題未能解決,我除了嘗試停了所有exchange 2007及iis services後將owa virtual directory 剷除再重新安裝後問題仍然持續,另外我在event viewer發現有event id 1310的出現,可是我仍未尋找到任何solution, 可否麻煩你有没有其他意見?謝謝~~
    2008年10月28日 下午 04:57
  • 你好

    經過多日的努力,終於搞掂了~嘗試了很多方法,現在提供一個自己嘗試出來的解決方案

    1. Disable all exchange 2007 services
    2. stop IIS services and in the local computer-->website-->default web site, delete owa, exchweb, oab  component
    3. update the .net framework 1.0 services pack1
    4. remove and reinstall the CAR(in control panel-->add and remove)
    5. Goto administrator tools-->services-->start all exchange 2007 services(regards POP3 and IMAP4 default is manual start up, you need change to auto.)
    6. start IIS and test again.
    2008年10月28日 下午 06:38