locked
issue when RDP to windows 2003 server RRS feed

  • 問題

  •  

    one of the windows 2003 server not able to allow anyone (including local admin and domain admin) to do the RDP. the error message is: the system cannot log you on due to the following error: The RPC server is unavailable. please try again or consult your system administator:

     

    I use the console from the iLO to remote login to this server, the PRC is start. I also try to reboot the server but the error still occur.

     

    This server should able to allow RDP. this happen so sudden few months ago.

    2009年1月2日 上午 08:56

解答

  • Dear Customer,

     

    Thank you for your post.

     

    Based on my research, there are many possible causes for this problem. It may need us intensive trouble shooting to locate the root cause for this issue. I will try my best to help you resolve it efficiently and I appreciate your efforts.

     

    Please perform the following steps one by one. After each step, please check whether this problem continues, if not,

     

    Suggestion 1: Check DNS

    -------------------------

    Please verify DNS is properly configured on the RDP server. If the server is has more than one network adapter in use,  all of them must point only to valid internal DNS servers that are authoritative for the domain. If external name resolution is required, then forwarders need to be properly configured per KB article 323380 for Windows 2003.

     

    http://support.microsoft.com/?id=323380

     

    Suggestion 2:

    -------------------------

    Ensure that the TCP/IP NETBIOS Helper service is started and the "Start Type" is set to "Automatic".

     

    Suggestion 3:

    -------------------------

    This problem may also occur when the RDP server cannot communicate with the domain controller properly. Please use the default domain Administrator account to log locally on that problematic Windows Server 2003 server. If this problem continues, please disjoin and then rejoin the server to the domain to test this issue.

     

    Suggestion 4:

    -------------------------

    Some third party firewall or packet filter applications may filter the RPC traffic. Please temporarily disable or uninstall this kind of applications to test again.

     

    Suggestion 5: Set IgnoreRegUserConfigErrors value

    ---------------------------------------------

     

    We may edit the Windows registry on the server to resolve the issue. To do so, follow these steps.

     

    1. Click "Start", click "Run", type "regedit" in the "Open" box, and then click "OK".

    2. Locate the following registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server

    3. On the "Edit" menu, point to "New", and then click "DWORD Value".

    4. In the "New Value #1" box, type "IgnoreRegUserConfigErrors" and then press ENTER.

    5. Right-click "IgnoreRegUserConfigErrors" and then click "Modify".

    6. In the "Value data" box, type "1" (without the quotation marks) (one), click "Decimal", and then click "OK".

    7. Quit Registry Editor.

     

    Hope the above information helps. If you have any further questions or concerns, please feel free to let me know. I am happy to be of assistance.

     

    Sincerely,


    Tom Zhang

    2009年1月5日 上午 09:45
    版主

所有回覆

  • Please check the following:

     

    1. If there have any firewall enabled, please check if it is already allowed for RDP port

    2. Check on the Control Panel -> Services and see if "remote registry" services and the other services is operated normally.

     

    2009年1月4日 上午 09:21
  • Please try to check the following items:-

    1. Network card DNS settings
    2. System Time and Time zone settings
    3. "TCP/IP NetBIOS Helper" service
    4. "Remote Registry" service

     

    Detail, please refer to below web link:-

    http://support.microsoft.com/kb/555839/en-us

    2009年1月5日 上午 03:04
  • Dear Customer,

     

    Thank you for your post.

     

    Based on my research, there are many possible causes for this problem. It may need us intensive trouble shooting to locate the root cause for this issue. I will try my best to help you resolve it efficiently and I appreciate your efforts.

     

    Please perform the following steps one by one. After each step, please check whether this problem continues, if not,

     

    Suggestion 1: Check DNS

    -------------------------

    Please verify DNS is properly configured on the RDP server. If the server is has more than one network adapter in use,  all of them must point only to valid internal DNS servers that are authoritative for the domain. If external name resolution is required, then forwarders need to be properly configured per KB article 323380 for Windows 2003.

     

    http://support.microsoft.com/?id=323380

     

    Suggestion 2:

    -------------------------

    Ensure that the TCP/IP NETBIOS Helper service is started and the "Start Type" is set to "Automatic".

     

    Suggestion 3:

    -------------------------

    This problem may also occur when the RDP server cannot communicate with the domain controller properly. Please use the default domain Administrator account to log locally on that problematic Windows Server 2003 server. If this problem continues, please disjoin and then rejoin the server to the domain to test this issue.

     

    Suggestion 4:

    -------------------------

    Some third party firewall or packet filter applications may filter the RPC traffic. Please temporarily disable or uninstall this kind of applications to test again.

     

    Suggestion 5: Set IgnoreRegUserConfigErrors value

    ---------------------------------------------

     

    We may edit the Windows registry on the server to resolve the issue. To do so, follow these steps.

     

    1. Click "Start", click "Run", type "regedit" in the "Open" box, and then click "OK".

    2. Locate the following registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server

    3. On the "Edit" menu, point to "New", and then click "DWORD Value".

    4. In the "New Value #1" box, type "IgnoreRegUserConfigErrors" and then press ENTER.

    5. Right-click "IgnoreRegUserConfigErrors" and then click "Modify".

    6. In the "Value data" box, type "1" (without the quotation marks) (one), click "Decimal", and then click "OK".

    7. Quit Registry Editor.

     

    Hope the above information helps. If you have any further questions or concerns, please feel free to let me know. I am happy to be of assistance.

     

    Sincerely,


    Tom Zhang

    2009年1月5日 上午 09:45
    版主
  • Dear Customer,

     

    Thank you for your post.

     

    Based on my research, there are many possible causes for this problem. It may need us intensive trouble shooting to locate the root cause for this issue. I will try my best to help you resolve it efficiently and I appreciate your efforts.

     

    Please perform the following steps one by one. After each step, please check whether this problem continues, if not,

     

    Suggestion 1: Check DNS

    -------------------------

    Please verify DNS is properly configured on the RDP server. If the server is has more than one network adapter in use,  all of them must point only to valid internal DNS servers that are authoritative for the domain. If external name resolution is required, then forwarders need to be properly configured per KB article 323380 for Windows 2003.

     

    http://support.microsoft.com/?id=323380

     

    Suggestion 2:

    -------------------------

    Ensure that the TCP/IP NETBIOS Helper service is started and the "Start Type" is set to "Automatic".

     

    Suggestion 3:

    -------------------------

    This problem may also occur when the RDP server cannot communicate with the domain controller properly. Please use the default domain Administrator account to log locally on that problematic Windows Server 2003 server. If this problem continues, please disjoin and then rejoin the server to the domain to test this issue.

     

    Suggestion 4:

    -------------------------

    Some third party firewall or packet filter applications may filter the RPC traffic. Please temporarily disable or uninstall this kind of applications to test again.

     

    Suggestion 5: Set IgnoreRegUserConfigErrors value

    ---------------------------------------------

     

    We may edit the Windows registry on the server to resolve the issue. To do so, follow these steps.

     

    1. Click "Start", click "Run", type "regedit" in the "Open" box, and then click "OK".

    2. Locate the following registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server

    3. On the "Edit" menu, point to "New", and then click "DWORD Value".

    4. In the "New Value #1" box, type "IgnoreRegUserConfigErrors" and then press ENTER.

    5. Right-click "IgnoreRegUserConfigErrors" and then click "Modify".

    6. In the "Value data" box, type "1" (without the quotation marks) (one), click "Decimal", and then click "OK".

    7. Quit Registry Editor.

     

    Hope the above information helps. If you have any further questions or concerns, please feel free to let me know. I am happy to be of assistance.

     

    Sincerely,


    Tom Zhang

    2009年1月5日 上午 09:45
    版主
  • Dear Customer,

     

    I just wanted to say hi, and to see how things are going. I haven't heard back from you yet and I was wondering if there are any updates on the service request.

     

    Thanks.

     

    Sincerely


    Tom Zhang

     

    2009年1月7日 上午 01:24
    版主