none
請問有關SQL Server 2008 R2 Database Mirroring 見證伺服器 RRS feed

  • 問題

  • 您好:

    我在嘗試建置SQL Server 2008 R2 Database Mirroring 時,參考了相關的文件。

    http://msdn.microsoft.com/zh-tw/library/ms188712(v=sql.105).aspx

    關於見證伺服器的部分,可以使用SQL SERVER 2008 Express版本就好。

    但我在嘗試加入該機器時,卻出現"xxxx不是有效的鏡像伺服器執行個體SQL SERVER必須為ENTERPRISE STANDARD 或DEVELOPER版本"?

    我的兩台主要SQL版本是SQL Server 2008 R2 Standard

    見證伺服器是SQL Server 2008 R2 Express with Advance Service版本

    請問原因大概是什麼?感謝您!


    • 已編輯 alexsu7 2013年7月10日 下午 01:47 Wrong type
    2013年7月10日 上午 10:08

解答

  • The error you got doesn't sound for witness. Did you set mirror in HS mode? How did you add witness? All servers are in same domain?
    • 已標示為解答 alexsu7 2013年7月11日 下午 03:16
    2013年7月10日 下午 04:02

所有回覆

  • You need sql2k8 r2 express at least for witness.
    2013年7月10日 下午 01:07
  • Her is my apologize. I typed too fast. I was using MS SQL Server 2008 R2 Express with Advanced Services be my witness server. I had already corrected it now. Thank you so much
    2013年7月10日 下午 01:53
  • The error you got doesn't sound for witness. Did you set mirror in HS mode? How did you add witness? All servers are in same domain?
    • 已標示為解答 alexsu7 2013年7月11日 下午 03:16
    2013年7月10日 下午 04:02
  • 您好,感謝您的提醒。

    問題已經解決了。

    在建置DataBase Mirroring的過程中,會先需加入被鏡像的伺服器,再選擇見證伺服器。

    而我在"加入被鏡像的伺服器"時,選錯了,選成了SQL Express with Advanced Services的instance。所以一直加不進去。

    感謝您的解答。

    2013年7月11日 下午 03:16
  • Happy SQLing!
    2013年7月11日 下午 04:40