locked
Windows 7 client can not access win2003 server by hostname RRS feed

  • 問題

  • Dear Sir

    問題:Win7使用者不能使用名稱連線主機

    伺服器OS:Windows 2003 R2 English 32bit (已經運作兩年)   

    有問題用戶端

    1. OS:windows 7 Entrerprise English 32 bit (Logon local administrator)
    2. OS:windows 7 Entrerprise English 32 bit (logon Domain admin)
    3. OS:windows 7 Professional Chinese 32bit(Logon local administrator)

    PS:Connect to 2003 server used account is domain administrator.

    先告知windows XP all user 都沒問題,問題出現在windows 7使用者.

    連結\\IP winXP and win7 ok 沒問題

    連結\\hostname.domain.com.tw  winXP and win7 ok 沒問題

    狀況: 

    連結\\hostname winXP 沒問題,win7 出現權限不足.訊息如下:

    \\hostname is not accesiable. You might not have permission to use this network resource.

    Connect the administrator of this server to find out if you have access permissions.

    Logon Failure:The target account name is incorrect.

     

    Miki Wang

    2010年4月12日 上午 08:58

解答

  • any result when you try  to "ping hostname"?
    大家一齊探討、學習和研究,謝謝!
    Microsoft MVP, Microsoft Community Star(TW & HK), MCT,
    MCSD, MCAD, MCSE+I, MCDBA, MCDST, MCSA, MCTS, MCITP, MCPD
    2010年4月15日 上午 06:57
  • Try to on your Windows 7 machine, create a user name and password same as your domain account. Then logoff and logon using the domain account, browse the folder again.

    It is a known bug in Windows 7

    2010年4月18日 下午 02:08

所有回覆

  • Try to enable NetBIOS over TCP/IP on Windows 7:

    1. Click Start, and then click Network.  (click Start, type ncpa.cpl into the search box for  Windows 7 or Vista, hit ENTER).
    2. Click on the Network and Sharing Center
    3. Click Manage Network Connections.
    4. Right click on the Local Area Connection select Properties.
    5. Select Internet Protocol version 4 (TCP/IPv4)
    6. Click the Advanced button under the General tab.
    7. Click the WINS tab.
    8. Click Enable NetBIOS Over TCP/IP.
    9. Click OK and Exit the settings.

     

    Also try this, On the Windows 7  computers, please go to “Control Panel\All Control  Panel Items\Network and Sharing Center\Advanced sharing settings” and  ensure that the following items are turned on:
    1) Network Discovery
    2) File and printer sharing

    And this one is OFF:
    1) Password protected sharing


    大家一齊探討、學習和研究,謝謝!
    Microsoft MVP, Microsoft Community Star(TW & HK), MCT,
    MCSD, MCAD, MCSE+I, MCDBA, MCDST, MCSA, MCTS, MCITP, MCPD
    2010年4月13日 上午 05:07
  • Dear Sir

    測試後您的兩個方法,依然無法利用\\hostname 連線,請問還有其他地方要確認的嗎?

    Miki

    2010年4月15日 上午 02:14
  • any result when you try  to "ping hostname"?
    大家一齊探討、學習和研究,謝謝!
    Microsoft MVP, Microsoft Community Star(TW & HK), MCT,
    MCSD, MCAD, MCSE+I, MCDBA, MCDST, MCSA, MCTS, MCITP, MCPD
    2010年4月15日 上午 06:57
  • Try to on your Windows 7 machine, create a user name and password same as your domain account. Then logoff and logon using the domain account, browse the folder again.

    It is a known bug in Windows 7

    2010年4月18日 下午 02:08