locked
Force Protocol for Sharing RRS feed

  • 問題

  • How to force the sharing protocol?

    Configuration:
    1 - Windows Server 2003 Standard Edition Service Pack 2
    Numerous Windows XP Professional clients

    I have file shares setup on the server for access via the XP clients.  Two Groups have been created for the clients -- one for User (readonly) and one for Operators (full access).  For each share I remove the "everyone" account in the "sharing" properties and add the proper group with full access.  I then control the access under the "security" properties for a given share.  This configuration mostly works fine, however I am attempting to troubleshoot a few connectivities issues and would like some feedback.

    I am using WireShark to analyze the SMB protocol, which helps me locate configuration problems.  I also use Auth Diag and various other Microsoft Tools for Web configuration.  WireShark will show the SMB handshake, session setup and tree connect.  I can work out most problems from that information.

    I have one XP client that works for each Operator except one.  When that person attempts to run the software which connects to the server, they receive an "access denied" error.  And they are definately in the Operator group for the server.  When I run WireShark I see "DCE RPC" interaction, but no SMB handshaking.  This same machine works for other users, so it must be a Group Policy setting.  Perhaps the "Provider Order" is at issue.  

    For some reason this user is resorting to the older port 135 for sharing.  The "DCE RPC" gives a "nca access denied" error in response to a RemoteCreateInstance.  I'm not clear on what this is all about.

    Any thoughts would be appreciated.

    dgp

       

    2009年3月17日 下午 04:43

解答

  • You should required to using some account to access the sharing. You may try to goes to the XP computers, type the share name in the explorer, and see if you get same result using the account. You may need to check the share permission using "effective permission" tab in Windows Server, right click the share name and see "Advance" folder
    2009年3月22日 下午 03:15

所有回覆

  • You should required to using some account to access the sharing. You may try to goes to the XP computers, type the share name in the explorer, and see if you get same result using the account. You may need to check the share permission using "effective permission" tab in Windows Server, right click the share name and see "Advance" folder
    2009年3月22日 下午 03:15
  • Dear Customer,

    I agree with Jack
    ’s suggestion.

     

    If there is anything unclear, please feel free to contact me.


    Sincerely


    Tom Zhang


    Tom Zhang – MSFT
    2009年3月25日 上午 02:32
    版主