locked
Show default login name in computer by group policy RRS feed

  • 問題

  • Dear Sir,

    Please kindly advise me how to show default login name by policy.

    Important: "only" show the login name on welcome screen. It is different from auto-login by default user!

    For example,

    PC01 will be login by sam@abc.local. 

    No matter  the last login of PC01 is may@abc.local,it will show login name:sam@abc.local and request password after restart or logout.

    Can I set it by group policy?


    • 已編輯 一奇 2012年5月21日 上午 02:19 add importat thing
    2012年5月19日 上午 03:44

解答

  • Hi,

    In any previous Windows Server OS you can designate via a drop down list whether you wish to have the account login into the domain or the local computer.

    You can usingGroup Policy to set the default domain that you want to login in Windows server 2008.

    You can configure the policy inComputer Configuration, Administrative Templates, System, Logon, Assign a default domain for logon. Enable that policy, and enter the DOMAIN part from DOMAIN\username. Then type thegpupdate /force in the DC and TS, you can default to logon the domain and not the TS local.

    Please also refer to the following post:

    http://social.technet.microsoft.com/Forums/en-US/winserversecurity/thread/bb98d388-7f4b-42d5-9a95-652ee7e95ff3


    如果您对我们的论坛在线支持服务有任何的意见或建议,请通过邮件告诉我们。
    Description: Description: TechNet 论坛好帮手立刻免费下载  TechNet 论坛好帮手

    2012年5月21日 上午 08:45
    版主
  • Hi,

    I've been searching for an answer to this also and after searching through the registry, finally discovered the location for this in the Windows 7 registry. The key is found here:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI

    To set the logon screen to display just "Other User" use this registry edit:

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI]
    "LastLoggedOnProvider"=""
    "LastLoggedOnSAMUser"=""
    "LastLoggedOnUser"=""

    So far this has been working on a Win7 64bit Enterprise test machine but haven't test on others yet.

    Hope this helps.


    如果您对我们的论坛在线支持服务有任何的意见或建议,请通过邮件告诉我们。
    Description: Description: TechNet 论坛好帮手立刻免费下载  TechNet 论坛好帮手

    2012年6月5日 上午 09:43
    版主

所有回覆

  • Hi,

    In any previous Windows Server OS you can designate via a drop down list whether you wish to have the account login into the domain or the local computer.

    You can usingGroup Policy to set the default domain that you want to login in Windows server 2008.

    You can configure the policy inComputer Configuration, Administrative Templates, System, Logon, Assign a default domain for logon. Enable that policy, and enter the DOMAIN part from DOMAIN\username. Then type thegpupdate /force in the DC and TS, you can default to logon the domain and not the TS local.

    Please also refer to the following post:

    http://social.technet.microsoft.com/Forums/en-US/winserversecurity/thread/bb98d388-7f4b-42d5-9a95-652ee7e95ff3


    如果您对我们的论坛在线支持服务有任何的意见或建议,请通过邮件告诉我们。
    Description: Description: TechNet 论坛好帮手立刻免费下载  TechNet 论坛好帮手

    2012年5月21日 上午 08:45
    版主
  • Hello, Tom,

    Thank for your advise. but it does not work.

    There is simple network just DC(win2008r2) and clients only.

    I have to go group policy and set delegation on PC01(win7),PC02(winXP) read,then edit policy:

    Computer COnfiguration,Policy,Administrative templates,system,logon,

    Assign a default domain for login.

    I enable it

    Next I type may@abc.local   or  abc/may or MAY@ABC.LOCAL or ABC/MAY (I try 4 times)

    Then gpupdate /force on DC and clients(PC01 & PC02) both

    Clients restart and login by sam@abc.local and restart.....but it still show sam@abc.local rather than may@abc.local on PC01 and PC02

    Please kindly advise me what is the problem?

    2012年5月24日 上午 02:50
  • Hi,

    I've been searching for an answer to this also and after searching through the registry, finally discovered the location for this in the Windows 7 registry. The key is found here:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI

    To set the logon screen to display just "Other User" use this registry edit:

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI]
    "LastLoggedOnProvider"=""
    "LastLoggedOnSAMUser"=""
    "LastLoggedOnUser"=""

    So far this has been working on a Win7 64bit Enterprise test machine but haven't test on others yet.

    Hope this helps.


    如果您对我们的论坛在线支持服务有任何的意见或建议,请通过邮件告诉我们。
    Description: Description: TechNet 论坛好帮手立刻免费下载  TechNet 论坛好帮手

    2012年6月5日 上午 09:43
    版主