locked
Error trying to delete Task RRS feed

  • Frage

  • Hello,

    in a view which shows "My Activities", when I mark one Task, and click Delete, I get error "Record is Unavailable". Trace logs that its trying to find appointment instead of task:

     

    >System.Web.HttpUnhandledException: Microsoft Dynamics CRM has experienced an error. Reference number for administrators or support: #B2B66C01: System.Web.HttpUnhandledException (0x80004005): Exception of type 'System.Web.HttpUnhandledException' was thrown. ---> Microsoft.Crm.CrmException: appointment With Id = a0fea1ba-7a3e-e011-bb2b-002618f7c9ac Does Not Exist

     

    If I open the Task in a form view, then I can delete it. Also, if I select a view which shows only tasks, like "My Tasks", then delete works aswell.

     

    Is this a bug?

    Dienstag, 15. März 2011 23:14

Antworten

  • You'll want to post this on the Connect site if you believe it is a bug or something is not working as expected.


    Regards, Donna

    • Als Antwort vorgeschlagen Donna EdwardsMVP Montag, 11. April 2011 18:46
    • Als Antwort markiert algkep Mittwoch, 13. April 2011 10:58
    Montag, 11. April 2011 18:46
  • Hi,

     

           Joextreme, Thanks for the Information. Based on your info i tried your work around and got the solution.

    Some of the Views missing an XML Element  <cell name="instancetypecode" width="100" ishidden="1" />, After adding this element to those views I am not getting that error.

     

    So Export the solution and open the Customization.Xml file in edit mode. Now find the newly created views or Views which are having this issue, Add the  <cell name="instancetypecode" width="100" ishidden="1" /> tag to the grid Element of the view. Now import back the solution.

    <grid name="resultset" object="4200" jump="subject" select="1" icon="1" preview="1">

                    <row name="result" id="activityid" multiobjectidfield="activitytypecode">

                      <cell name="activitytypecode" width="100" />

                      <cell name="subject" width="300" />

                      <cell name="regardingobjectid" width="100" />

                      <cell name="prioritycode" width="100" />

                      <cell name="actualend" width="100" />

                      <cell name="instancetypecode" width="100" ishidden="1" />

                    </row>

                  </grid>

     

    Hope this will helps..


    Guru Prasad
    Mittwoch, 31. August 2011 07:07

Alle Antworten

  • if I select two ore more records it deletes fine.

     

    the bug is that it incorrectly identifies the type of activity..

    Mittwoch, 16. März 2011 00:52
  • anyone with the same issue?
    Donnerstag, 7. April 2011 15:12
  • Have you tried restarting the Async service on your CRM server?
    Thanks, God bless! Michael C. | Using CRM 4.0, Rollup 7
    Donnerstag, 7. April 2011 20:25
  • I found the issue during extensive debugging and compare CRM Online to our deployment. On our deployment, in data grid, it does not add attribute "instancetypecode" to each table row. Script does not find it, thinks it is a recurring activity, and thus directs to wrong action. Question is, why isnt instancetypecode added to the data grid?
    Freitag, 8. April 2011 07:24
  • actually, the same can be replicated in CRM Online, so this definitely is a bug.  
    Freitag, 8. April 2011 14:21
  • You'll want to post this on the Connect site if you believe it is a bug or something is not working as expected.


    Regards, Donna

    • Als Antwort vorgeschlagen Donna EdwardsMVP Montag, 11. April 2011 18:46
    • Als Antwort markiert algkep Mittwoch, 13. April 2011 10:58
    Montag, 11. April 2011 18:46
  • I will, but that's taking ages..
    Mittwoch, 13. April 2011 10:58
  • You need to get the entry voted up when you put it on the Connect site so it gets more attention.  If you provide the link, I'll vote for it and you can get others to vote for it as well.

    If you want a faster response to address a 'bug' issue, the only way I know to do that is open a Support Ticket.

    I hope this helps!


    Regards, Donna

    Mittwoch, 13. April 2011 12:43
  • Did you post this problem to Connect? I have the same issue. I would like to vote for it, can you send me the link? Or did you open support ticket?

    Thanks


    Pavel Brestovsky
    Freitag, 1. Juli 2011 15:47
  • If you provide the number I will also vote for it!

    Freitag, 15. Juli 2011 13:20
  • It is a known bug microsoft is working on, work around is to add <cell name instancetypecode there is more to this, i forget) you will add that to the export xml file in savedquery in the rows.  It will be sickening knowing you will have to do this each time you create a view, not sure if there is an easier way to update this in sql, i know there is, which isn't supported by mircrost so always best to back up your org db in trying to use sql statements to update the savedquery view.
    Dienstag, 2. August 2011 01:46
  • Hi Algkep,

     

          I am also having the same issue? Have you found any solution for this? Is it a known issue or bug ?

     

    We have upgraded CRM4.0 to CRM 2011, then we are having this issue while deleting activities. With default CRM 2011 organization we are not getting this issue.

    Is there any issue with the up-gradation environments?

     

    Any help much appreciated..


    Guru Prasad
    Mittwoch, 31. August 2011 05:05
  • Hi Joextreme,

     

          Can you explain more about the work around for this issue? I am not clear on the solution which you have provided.

     

     

    Thanks..


    Guru Prasad
    Mittwoch, 31. August 2011 05:14
  • Hi,

     

           Joextreme, Thanks for the Information. Based on your info i tried your work around and got the solution.

    Some of the Views missing an XML Element  <cell name="instancetypecode" width="100" ishidden="1" />, After adding this element to those views I am not getting that error.

     

    So Export the solution and open the Customization.Xml file in edit mode. Now find the newly created views or Views which are having this issue, Add the  <cell name="instancetypecode" width="100" ishidden="1" /> tag to the grid Element of the view. Now import back the solution.

    <grid name="resultset" object="4200" jump="subject" select="1" icon="1" preview="1">

                    <row name="result" id="activityid" multiobjectidfield="activitytypecode">

                      <cell name="activitytypecode" width="100" />

                      <cell name="subject" width="300" />

                      <cell name="regardingobjectid" width="100" />

                      <cell name="prioritycode" width="100" />

                      <cell name="actualend" width="100" />

                      <cell name="instancetypecode" width="100" ishidden="1" />

                    </row>

                  </grid>

     

    Hope this will helps..


    Guru Prasad
    Mittwoch, 31. August 2011 07:07